PAT1054. 求平均值

本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。


输入格式:


输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。


输出格式:


对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。


输入样例1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例2:
2
aaa -9999
输出样例2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number

The average of 0 numbers is Undefined

思路:判断每个输入的数是否符合标准
通过小数点为边界分为整数部分和小数部分,小数点只有一个,出现多余和其他字符代表不是一个数,最后判断范围

#include<cstdio>
#include<string.h>
#include<iostream>
//#include<algorithm>
using namespace std;
const int maxn = 1010;
double sum = 0;
int ave = 0;
struct Number{
	char str[maxn];
	double num;
	bool valid;
}nu[110];
int main()
{
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++){
		scanf("%s", &nu[i].str);
		int len = strlen(nu[i].str);
		int j = 0, exect = 0;
		double num = 0;
		char sy = '+';
		bool point = false;
		if (nu[i].str[0] == '-'){
			j = 1;
			sy = '-';
		}
		while (j < len && (nu[i].str[j] >= '0'&&nu[i].str[j] <= '9' || nu[i].str[j] == '.')){
			if (nu[i].str[j] == '.'&&point == false){
				if (sy == '-'&&j>1)
					point = true;
				else if (sy == '+'&&j > 0)
					point = true;
				else
					break;
			}
			else if (nu[i].str[j] >= '0'&&nu[i].str[j] <= '9'&&point == false){
				num = num * 10 + (nu[i].str[j] - '0');
			}
			else if (nu[i].str[j] >= '0'&&nu[i].str[j] <= '9'&&point == true){
				if (exect == 0)
					num += (nu[i].str[j] - '0')*0.1;
				if (exect==1)
					num += (nu[i].str[j] - '0')*0.01;
				exect++;
				if (exect > 2)
					break;
			}
			else
				break;
			j++;
		}
		if (j != len)
			nu[i].valid = false;
		else if (num <= 1000 && num >= -1000)
		{
			nu[i].valid = true;
			ave++;
			if (sy == '-')
				num = -num;
			nu[i].num = num;
			sum += num;
		}
	}
	for (int i = 0; i < n; i++){
		if (nu[i].valid == false){
			printf("ERROR: %s is not a legal number\n", nu[i].str );
		}
	}
	if (ave > 0 && ave != 1)
		printf("The average of %d numbers is %.2f\n", ave, sum / ave);
	else if (ave == 1)
		printf("The average of 1 number is %.2f\n", sum);
	else
		printf("The average of 0 numbers is Undefined\n");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值