HDU 1016(Prime Ring Problem)

                                              Prime Ring Problem
           Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                        Total Submission(s): 70037    Accepted Submission(s): 29967

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
6
8

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

#include<iostream>
#include<cmath>
using namespace std;
int n;
bool fun2(int * a,int c,int b)
{
	int m=0,j;
	for(j=0;j<b;j++)
	{
		if(a[j]==c)
		{
			m=1;
			break;
		}
	}
	if(m==1)
	{
		return false;
	}
	else
	{
		return true;
	}
}
bool fun1(int c,int d)
{
	int m=0,i;
	for(i=2;i<=sqrt(c+d);i++)
	{
		if((c+d)%i==0)
		{
			m=1;
			break;
		}
	}
	if(m==1)
	{
		return false;
	}
	else
	{
		return true;
	}
}
int fun(int * a,int b)
{
	int i;
	if(b==n)
	{
		if(fun1(a[b-1],a[0]))
		{
			for(i=0;i<b;i++)
			{
				cout<<a[i];
				if(i!=(b-1))
					cout<<' ';
			}
			cout<<endl;
		}
		return 0;
	}
	else
	{
		for(i=2;i<=n;i++)
		{
			if(fun2(a,i,b))
			{
				if(fun1(a[b-1],i))
				{
					a[b]=i;
					fun(a,++b);
					b--;
				}
			}
		}
		return 0;
	}
}
int main()
{
	int a[21]={0},i,cnt=0,s=1;
	while(cin>>n)
	{
		cout<<"Case "<<s<<":"<<endl;
		cnt=0;
		a[cnt]=1;
		fun(a,++cnt);
		cnt--;
		cout<<endl;
		s++;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值