用DFS求连通块

这是一篇关于如何利用深度优先搜索(DFS)算法来分析土地网格中石油沉积物的连通区域的问题。GeoSurvComp公司负责检测地下石油沉积,将土地划分为小正方形地块,如果相邻地块都含有石油,则它们属于同一油藏。任务是确定在给定的网格中有多少个不同的石油沉积区块。
摘要由CSDN通过智能技术生成

uva572:    Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise $1 \le m \le 100$ and $1 \le n \le 100$. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ` *', representing the absence of oil, or ` @', representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output 

0
1
2
2
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
const int maxn = 100 + 10;

char dep[maxn][maxn];
int id[maxn][maxn]; //标记联通量id
int row, col;

void dfs(int r, int c, int num) {
    if(r >= row || r < 0 || c >= col || c < 0)  return;     //越界返回
    if(dep[r][c] != '@' || id[r][c] != 0)   return; //被访问过或者不是油田
    id[r][c] = num;

    for(int i = -1; i <= 1; i++)
        for(int j = -1; j <= 1; j++)
            if(i != 0 || j != 0)    dfs(r + i, c + j, num);     //向周围8个方向深搜,注意if()中的条件,不遍历自己,否则就无限循环下去
}

int main()
{
    while(scanf("%d%d", &row, &col) == 2 && row && col) {
        for(int i = 0; i < row; i++)
            scanf("%s", dep[i]);

        int num = 0;
        memset(id, 0, sizeof(id));
        for(int i = 0; i < row; i++)
        for(int j = 0; j < col; j ++) {
            if(id[i][j] == 0 && dep[i][j] == '@')   dfs(i, j, ++num);
        }
        printf("%d\n", num);
    }
    return 0;
}

备注:对多维数组求联通块的过程也称之为“种子填充”。附上维基百科里面对于“种子填充”的介绍,动画很不错!https://en.wikipedia.org/wiki/Flood_fill
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值