HDU5606 tree 无向图 dfs求联通块

tree


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1126    Accepted Submission(s): 505




Problem Description
There is a tree(the tree is a connected graph which contains n points and n−1 edges),the points are labeled from 1 to n,which edge has a weight from 0 to 1,for every point i∈[1,n],you should find the number of the points which are closest to it,the clostest points can contain i itself.
 


Input
the first line contains a number T,means T test cases.


for each test case,the first line is a nubmer n,means the number of the points,next n-1 lines,each line contains three numbers u,v,w,which shows an edge and its weight.


T≤50,n≤105,u,v∈[1,n],w∈[0,1]
 


Output
for each test case,you need to print the answer to each point.


in consideration of the large output,imagine ansi is the answer to point i,you only need to output,ans1 xor ans2 xor ans3.. ansn.
 


Sample Input
1
3
1 2 0
2 3 1
 


Sample Output
1


in the sample.


$ans_1=2$


$ans_2=2$


$ans_3=1$


$2~xor~2~xor~1=1$,so you need to output 1.
 


Source
BestCoder Round #68 (div.2)
 


题意:给一棵树,边权是1则不能联通,0可以联通,每个结点有自己的编号,最后输出每个结点跟自己互相联通的个数的总异或结果。

思路:一开始想到用并查集,后来闲代码太多,就用图乱搞吧,时间复杂度是一样的都是O(n),但是我这个慢一点,用了vector比较耗时间。建图,权是0的建,权是1的不建,然后以每个点为起点dfs一遍,被访问过的不必再d,dfs的过程中记录下来访问了几个点,一遍d完时,如果是偶数不管,是奇数就用ans跟他^一下就好了。




#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <iomanip>
#include <time.h>
#include <set>
#include <map>
#include <stack>
using namespace std;
typedef long long LL;
const int INF=0x7fffffff;
const int MAX_N=10000;

int T,n;
vector<int>G[100009];
bool used[100009];
int cur,ans;
void dfs(int p){
    for(int i=0;i<G[p].size();i++){
        int a=G[p][i];
        if(!used[a]){
            cur++;
            used[a]=1;
            dfs(a);
        }
    }
}
int main(){
    cin>>T;
    while(T--){
        int x,y,w;
        cin>>n;
        memset(used,0,sizeof(used));
        for(int i=0;i<n-1;i++){
            scanf("%d%d%d",&x,&y,&w);
            if(w==1)continue;
            G[x].push_back(y);
            G[y].push_back(x);
        }

        ans=0;cur=0;
        for(int i=1;i<=n;i++){
            if(used[i]==0){
                cur=1;
                used[i]=1;
               // cout<<"dfs"<<i<<endl;
                dfs(i);
                //cout<<cur<<endl;
                if(cur%2==1)ans^=cur;

            }
        }

        for(int i=1;i<=n;i++){
            G[i].clear();
        }

        cout<<ans<<endl;
    }
    return 0;
}


  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值