poj 1308 Is It A Tree?_不见不散的结局是曲终人散_新浪博客

Is It A Tree?
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 26009Accepted: 8885

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.  

There is exactly one node, called the root, to which no directed edges point.  
Every node except the root has exactly one edge pointing to it.  
There is a unique sequence of directed edges from the root to each node.  
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.  
poj <wbr>1308 <wbr>Is <wbr>It <wbr>A <wbr>Tree?

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
题意:求输入的组合是否能成为一颗树;
思路:树的定义:1.只能有一个根节点;2.其中不能存在循环结;
#include< stdio.h >
#define max 1010
int f[max],r[max],k[max];
//f[]查找该节点的父亲节点,r[]标记该节点的根节点的个数,k[]标记该节点是否出现过
int find(int x)
{
    if(x!=f[x])
        f[x]=find(f[x]);
    return f[x];
}
int panduan()
{
    int i,t;
    for(i=0; i
    {
        if(k[i])
            ++r[find(i)];
    }
    t=0;
    for(i=0; i
    {
        if(r[i]>1)//如果为树,根节点永远只有一个,所有的r[]都应该为一,如果大于一,
            t++;
    }
    if(t>1)
        return 0;
    else return 1;
}
int main()
{
    int c=0;
    while(1)
    {
        int i,a,b,flag=0,x,y;
        for(i=0; i
        {
            f[i]=i;
            r[i]=0;
            k[i]=0;
        }
        while(scanf("%d%d",&a,&b))
        {
            if(a==0&&b==0||a<0&&b<0)
                break;
            x=find(a);
            y=find(b);
            k[a]=k[b]=1;//记录节点;
            if(x==y||y!=b)//x=y表示根节点相同,则构成环,y!=b了父亲节表示b已经有根节点,所以b的入度为二;
       
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值