HUST 1010 The Minimum Length

题目链接:HUST1010

1010 - The Minimum Length

Time Limit: 1s Memory Limit: 128MB

Submissions: 1672 Solved: 611 
DESCRIPTION
There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A="abcdefg". I got abcd efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.
INPUT
Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.
OUTPUT
For each line, output an integer, as described above.
SAMPLE INPUT
bcabcab
efgabcdefgabcde
SAMPLE OUTPUT
3
7

题意:给出一个字符串,问最小的循环节是多少。

题目分析:next求循环节。

//
//  main.cpp
//  HUST1010
//
//  Created by teddywang on 16/4/26.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[1000010];
int nexts[1000010],len;

void getnext()
{
    int i=0,j=-1;
    nexts[0]=-1;
    while(i<len)
    {
        if(s[i]==s[j]||j==-1)
        {
            nexts[++i]=++j;
        }
        else j=nexts[j];
    }
}

int main()
{
    while(~scanf("%s",s))
    {
        len=strlen(s);
        getnext();
        int l=len-nexts[len];
        cout<<l<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值