POJ2406 Power Strings

题目链接:POJ2406

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 41439 Accepted: 17231

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a. 

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

[Submit]   [Go Back]   [Status]   [Discuss]


题意:问这个串是最多以一个小串循环几次拼在一起的。

题目分析:还是求循环节,如果除下来有余数或者循环节就是原串本身就输出1。

//
//  main.cpp
//  POJ2406
//
//  Created by teddywang on 16/4/27.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[1000010];
int nexts[1000010];
int len;

void getnext()
{
    int i=0,j=-1;
    nexts[0]=-1;
    while(i<len)
    {
        if(j==-1||s[i]==s[j])
        {
            nexts[++i]=++j;
        }
        else j=nexts[j];
    }
}

int main()
{
    while(~scanf("%s",s))
    {
        if(s[0]=='.') break;
        len=strlen(s);
        getnext();
        int buf=len-nexts[len];
        int ans=0;
        if(buf==len||len%buf!=0)
            ans=1;
        else
        {
            ans=len/buf;
        }
        printf("%d\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值