poj-2406-Power Strings (kmp)

6 篇文章 0 订阅
Power Strings 
Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 157   Accepted Submission(s) : 59
Problem Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
 


Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
 


Output
For each s you should print the largest n such that s = a^n for some string a. 
 


Sample Input
abcd
aaaa
ababab
.
 


Sample Output
1
4

3

//poj-2406-Power Strings (字符串匹配KMP)
//题目大意:给你一列字符串;求这列字符串的循环节的循环次数;如,abcd各个字符都不同;它本身是一个循环节,所以答案是一;
//又如:ababab 的循环节是ab;循环三次;所以答案是三;
//解题思路:
//本题可利用kmp函数中getp函数(字符串匹配中对子串预处理的函数)的性质来解决;假设有一字符串str,长度为len;定义一个p[]数组;
//str经过getp函数处理后,如果 len%(len-p[len])==0,那么str是一个周期串;其循环节的长度是len-p[len];循环的次数是len/(len-p[len]).
#include<stdio.h>
#include<string.h>
#define K 1000100
char str1[K];
int count,len1,len2,p[K];
void getp(){
	int i=0,j=-1;
	p[i]=j;
	while(i<len1){
		if(j==-1||str1[i]==str1[j]){
			i++,j++;
			p[i]=j;}
		else
		j=p[j];
	}	
}

int main()
{ 
	int i,x;
	while(scanf("%s",str1)){
		if(strcmp(str1,".")==0)
		 break;
		 len1=strlen(str1);
		getp();
		x=len1%(len1-p[len1]);
		if(x==0)
		 printf("%d\n",len1/(len1-p[len1]));
		else
		 printf("1\n");
		}	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值