HDU3294 Girls' research

题目链接:HDU3294

Girls' research

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1581    Accepted Submission(s): 600


Problem Description
One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.
 

Input
Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1.
 

Output
Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".
If there are several answers available, please choose the string which first appears.
 

Sample Input
  
  
b babd a abcd
 

Sample Output
  
  
0 2 aza No solution!
 

Author
wangjing1111
 

题意:第一个字符是其对应的字符为a,其他字符依次对应,要求找出后面字符串的最长回文串,标记出起始点和终点以及转换后的字符串,回文串长度要求大于1

题目分析:找到最长回文串,标记,输出。

//
//  main.cpp
//  HDU3294(1
//
//  Created by teddywang on 16/6/8.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int p[222222<<1];
char s[222222<<1];
char t[222222];

int main()
{
    char c;
    while(cin>>c)
    {
        int z=c-'a';
        scanf("%s",t);
        int len=strlen(t);
        for(int i=len;i>=0;i--)
        {
            s[2*i+2]=t[i];
            s[2*i+1]='#';
        }
        s[0]='*';
        int id=0,maxlen=0,maxn=0,pi=0;
        for(int i=2;i<2*len+1;i++)
        {
            maxlen=p[id]+id-1;
            if(maxlen>i-1) p[i]=min(p[2*id-i],maxlen-i+1);
            else p[i]=1;
            while(s[i+p[i]]==s[i-p[i]]) p[i]++;
            if(p[i]>maxn)
            {
                maxn=p[i];
                pi=i;
            }
            if(id+p[id]<i+p[i]) id=i;
        }
        int pos=(pi-maxn)/2;
        
        if(maxn>2)
        {
            printf("%d %d\n",pos,pos+maxn-2);
            for(int i=pos;i<pos+maxn-1;i++)
                printf("%c",'a'+(t[i]-z-'a'+26)%26);
        }
        else printf("No solution!");
        cout<<endl;
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值