HDU5734 Acperience

题目链接:HDU5734

Acperience

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 746    Accepted Submission(s): 402


Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector  W=(w1,w2,...,wn) . Professor Zhang would like to find a binary vector  B=(b1,b2,...,bn)   (bi{+1,1}) and a scaling factor  α0  in such a manner that  WαB2  is minimum.

Note that   denotes the Euclidean norm (i.e.  X=x21++x2n , where  X=(x1,x2,...,xn) ).
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first line contains an integers  n   (1n100000)  -- the length of the vector. The next line contains  n  integers:  w1,w2,...,wn   (10000wi10000) .
 

Output
For each test case, output the minimum value of  WαB2  as an irreducible fraction " p / q " where  p q  are integers,  q>0 .
 

Sample Input
  
  
3 4 1 2 3 4 4 2 2 2 2 5 5 6 2 3 4
 

Sample Output
  
  
5/1 0/1 10/1
 

Author
zimpha
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5746  5743  5741  5740  5739 
 

题意:大概就是求方差,不过是求所有数据绝对值的方差。

题目分析:题目数据量是10000*1000,不过如果普通的求方差的做法求平方再求和的话ull也装不下,因此需要优化公式,这个不难化,最后的公式是(直接copy了下)∑i=1nwi2−1n(∑i=1n∣wi∣)2i=1nwi2n1(i=1nwi)2
 

//
//  main.cpp
//  Acperience
//
//  Created by teddywang on 2016/7/21.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
long long int T,n;
long long int num[100010];

long long int gcd(long long int a,long long int b)
{
    return a%b==0?b:gcd(b,a%b);
}

int main()
{
    cin>>T;
    while(T--)
    {
        cin>>n;
        long long int ans1=0,ans2=0;
        for(long long int i=0;i<n;i++)
        {
            scanf("%lld",&num[i]);
            if(num[i]<0) num[i]=-num[i];
            ans1+=num[i];
            ans2+=num[i]*num[i];
        }
        long long int buf=ans1*ans1;
        long long int c=gcd(buf,n);
        buf/=c;
        n/=c;
        printf("%lld/%lld\n",ans2*n-buf,n);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
内容介绍 项目结构: Controller层:使用Spring MVC来处理用户请求,负责将请求分发到相应的业务逻辑层,并将数据传递给视图层进行展示。Controller层通常包含控制器类,这些类通过注解如@Controller、@RequestMapping等标记,负责处理HTTP请求并返回响应。 Service层:Spring的核心部分,用于处理业务逻辑。Service层通过接口和实现类的方式,将业务逻辑与具体的实现细节分离。常见的注解有@Service和@Transactional,后者用于管理事务。 DAO层:使用MyBatis来实现数据持久化,DAO层与数据库直接交互,执行CRUD操作。MyBatis通过XML映射文件或注解的方式,将SQL语句与Java对象绑定,实现高效的数据访问。 Spring整合: Spring核心配置:包括Spring的IOC容器配置,管理Service和DAO层的Bean。配置文件通常包括applicationContext.xml或采用Java配置类。 事务管理:通过Spring的声明式事务管理,简化了事务的处理,确保数据一致性和完整性。 Spring MVC整合: 视图解析器:配置Spring MVC的视图解析器,将逻辑视图名解析为具体的JSP或其他类型的视图。 拦截器:通过配置Spring MVC的拦截器,处理请求的预处理和后处理,常用于权限验证、日志记录等功能。 MyBatis整合: 数据源配置:配置数据库连接池(如Druid或C3P0),确保应用可以高效地访问数据库。 SQL映射文件:使用MyBatis的XML文件或注解配置,将SQL语句与Java对象映射,支持复杂的查询、插入、更新和删除操作。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值