HDU 5761 多校联合 Rower BO

题目链接:HDU5761

Rower Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 650    Accepted Submission(s): 203
Special Judge


Problem Description
There is a river on the Cartesian coordinate system,the river is flowing along the x-axis direction.

Rower Bo is placed at  (0,a)  at first.He wants to get to origin  (0,0)  by boat.Boat speed relative to water is  v1 ,and the speed of the water flow is  v2 .He will adjust the direction of  v1  to origin all the time.

Your task is to calculate how much time he will use to get to origin.Your answer should be rounded to four decimal places.

If he can't arrive origin anyway,print"Infinity"(without quotation marks).
 

Input
There are several test cases. (no more than 1000)

For each test case,there is only one line containing three integers  a,v1,v2 .

0a100 0v1,v2,100 a,v1,v2  are integers
 

Output
For each test case,print a string or a real number.

If the absolute error between your answer and the standard answer is no more than  104 , your solution will be accepted.
 

Sample Input
  
  
2 3 3 2 4 3
 

Sample Output
  
  
Infinity 1.1428571429
 

题意:起始点是(0,a),终点是原点,船速v1,水速v2沿x轴,船头始终指向原点。问多长时间能到原点。

题目分析:官方题解:

首先这个题微分方程强解显然是可以的,但是可以发现如果设参比较巧妙就能得到很方便的做法。

先分解v1v1

Alt text

设船到原点的距离是rr,容易列出方程

drdt=v2cosθ−v1dtdr=v2cosθv1

dxdt=v2−v1cosθdtdx=v2v1cosθ

上下界都是清晰的,定积分一下:

0−a=v2∫0Tcosθdt−v1T0a=v20Tcosθdtv1T

0−0=v2T−v1∫0Tcosθdt00=v2Tv10Tcosθdt

直接把第一个式子代到第二个里面

v2T=v1v2(−a+v1T)v2T=v2v1(a+v1T)

T=v1av12−v22T=v12v22v1a

这样就很Simple地解完了,到达不了的情况就是v1<v2v1<v2(或者a>0a>0v1=v2v1=v2)。

物理老师,,,算了我是根据第二个样例找规律来的。

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    double a,v1,v2;
    while(cin>>a>>v1>>v2)
    {
        if(a==0) cout<<"0.000000"<<endl;
        else
        {
            if(v1<=v2)
                cout<<"Infinity"<<endl;
            else
            {
                double ans=(a*v1)/(v1*v1-v2*v2);
                printf("%.10lf\n",ans);
            }
        }
    }
}

 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值