HDU 5821 Ball 贪心+映射

题目链接:HDU5821

Ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 713    Accepted Submission(s): 424


Problem Description
ZZX has a sequence of boxes numbered  1,2,...,n . Each box can contain at most one ball.

You are given the initial configuration of the balls. For  1in , if the  i -th box is empty then  a[i]=0 , otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
 

Input
First line contains an integer t. Then t testcases follow. 
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
5 4 1 0 0 1 1 0 1 1 1 1 4 4 1 0 0 1 1 0 0 2 2 1 4 4 2 1 0 0 0 0 0 0 1 1 3 3 4 4 2 1 0 0 0 0 0 0 1 3 4 1 3 5 2 1 1 2 2 0 2 2 1 1 0 1 3 2 4
 

Sample Output
  
  
No No Yes No Yes
 

题意:有n个盒子,每个盒子只能放一个球,球的种类用1~n表示,0为没有球。给出m次操作,每次把l到r的所有球取出来再随机放回去,问有没有可能转化为给定的状态。

题目分析:将2个状态a和b建立映射的关系,每个球建立与之最近的相同的球关系,注意关系必须1对1,我们用mp数组来记录这个关系,比如数组ab分别为:1 2 0 2 1 和1 0 1 2 2,则mp数组为0,3,1,5,2。然后再根据每次操作的l和r把mp数组的l r范围内排序,最后排序得到的结果mp[i]==i都成立则可以转换,否则不可以。

贪心要素在于每次操作都将mp数组排序,仔细想一下也没什么问题,原因在于每次都将各种元素尽可能的使数组有序,有序即为每个数放到其对应的位置。

//
//  main.cpp
//  Ball
//
//  Created by teddywang on 2016/8/12.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1005],b[1005];
int n,m,vis[1005];
int mp[1005];
struct node {
    int l,r;
}q[1006];
int main()
{
    int T;
    scanf("%d\n",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&b[i]);
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&q[i].l,&q[i].r);
        }
        memset(vis,0,sizeof(vis));
        memset(mp,-1,sizeof(mp));
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(a[i]==b[j]&&!vis[j])
                {
                    mp[i]=j;
                    vis[j]=1;
                    break;
                }
            }
        }
        for(int i=0;i<m;i++)
        {
            sort(mp+q[i].l-1,mp+q[i].r);
        }
        int flag=0;
        for(int i=0;i<n;i++)
        {
            if(mp[i]!=i)
            {
                flag=1;
                printf("No\n");
                break;
            }
        }
        if(flag==0) printf("Yes\n");
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值