POJ 3067 Japan 树状数组

20 篇文章 0 订阅

题目链接:POJ 3067

Japan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27551 Accepted: 7451

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast. 

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

Source

题意:日本东海岸n座城市,西海岸m座,然后有许多路将东西海岸的2座城市连接起来,假设链接的是直线,问2海岸之间有多少交点。

题目分析:不考虑几条直线交于一点的情况,所以判断2条直线是否有交点只需考虑4个点的位置关系,x1<x2时,y1>y2就有交点,否则没有,所以先按x进行排序,之后树状数组统计逆序数即可,由于是统计前面大的数,所以当x相同时小的y要排在前面。

//
//  main.cpp
//  POJ3067 Japan
//
//  Created by teddywang on 2017/5/4.
//  Copyright © 2017年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
struct node{
    ll x,y;
    friend bool operator < (node a,node b)
    {
        if(a.x!=b.x)
            return a.x<b.x;
        else return a.y<=b.y;
    }
}t[1000011];

ll c[10000],r[10000];
int n,m,k;

ll lowbit(ll x)
{
    return x&(-x);
}

ll sum(ll x)
{
    ll ans=0;
    while(x!=0)
    {
        ans+=c[x];
        x-=lowbit(x);
    }
    return ans;
}

void update(ll x,ll a)
{
    while(x<=m)
    {
        c[x]+=a;
        x+=lowbit(x);
    }
}

int main()
{
    int T;
    cin>>T;
    int cas=1;
    for(cas=1;cas<=T;cas++)
    {
        memset(c,0,sizeof(c));
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<k;i++)
        {
            scanf("%lld%lld",&t[i].x,&t[i].y);
        }
        sort(t,t+k);
        long long ans=0;
        for(int i=0;i<k;i++)
        {
            update(t[i].y,1);
            ans+=sum(m)-sum(t[i].y);
        }
        printf("Test case %d: %lld\n",cas,ans);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值