HDU2509 Be the Winner Nim博弈

20 篇文章 0 订阅
题目链接: HDU2509

Be the Winner

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3246    Accepted Submission(s): 1814


Problem Description
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is 
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
 

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
 

Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
 

Sample Input
   
   
2 2 2 1 3
 

Sample Output
   
   
No Yes
 

题意:有几堆苹果,每堆都放成一列,一次可以在一堆中取连续的几个,最后取完的为负,问是否有必胜的算法。
题目分析:这题有取完后拆成2堆的情况,看似复杂了,其实和 HDU1907是一回事,考虑S2,S1,S0与T2,T0态相互转换的过程,发现多分出堆的情况只存在于有充裕堆的情况而此时不会影响到S2到T2,S1到T0的互相转化,也就是说多分出堆对游戏结果没有任何影响,沿用上题结论即可。
//
//  main.cpp
//  HDU2509
//
//  Created by teddywang on 2016/8/29.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int T,m,n;
int main()
{
    while(cin>>n)
    {
        int c[200];
        int ans=0,flag=0;
        for(int i=0;i<n;i++)
        {
            cin>>c[i];
            ans^=c[i];
            if(c[i]>1) flag++;
        }
        if((ans&&flag>=1)||(ans==0&&flag==0)) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值