HDOJ 5610-Baby Ming and Weight lifting

Baby Ming and Weight lifting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 222    Accepted Submission(s): 91


Problem Description
Baby Ming is fond of weight lifting. He has a barbell pole(the weight of which can be ignored) and two different kinds of barbell disks(the weight of which are respectively a and b ), the amount of each one being infinite.

Baby Ming prepare to use this two kinds of barbell disks to make up a new one weighted C (the barbell must be balanced), he want to know how to do it.


Input
In the first line contains a single positive integer T , indicating number of test case.

For each test case:

There are three positive integer a,b , and C .

1T1000,0<a,b,C1000,ab
 

Output
For each test case, if the barbell weighted C can’t be made up, print Impossible.

Otherwise, print two numbers to indicating the numbers of a and b barbell disks are needed. (If there are more than one answer, print the answer with minimum a+b )
 

Sample Input
  
  
2 1 2 6 1 4 5
 

Sample Output
  
  
2 2 Impossible
 

Source
题目大意:

就是给出a,b这两个杠铃盘的重量,给出C这个他想要举起这个杠铃的重量,在保证左右两边平衡的状态下,用最少的盘。

解题思路:
暴力即可,注意一下输出为 Impossible的情况。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f 
using namespace std;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        if(c%2!=0)
        {
            printf("Impossible\n");
        } 
        else
        {
            int ni=INF,wo1=INF;
            int ans1,ans2;
            int da,xiao;
            da=max(a,b);
            xiao=min(a,b);
            int uu=c/min(a,b);
            for(int i=0;i<=uu;i+=2)
            {
                if(((c-(xiao*i))/da)%2==0)
                {
                    ans1=i;
                    ans2=(c-(xiao*i))/da;
                    if(ans1*xiao+ans2*da==c)
                    {
                        ni=ans1;
                        wo1=ans2;
                        break;    
                    }
                }
            }
            if(ni==INF||wo1==INF)
            {
                printf("Impossible\n");    
            }
            else
            {
                if(a<b)
                printf("%d %d\n",ans1,ans2);
                else
                printf("%d %d\n",ans2,ans1);
            }
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值