HDOJ 5630-Rikka with Chess

Rikka with Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 111    Accepted Submission(s): 96


Problem Description
Yuta gives Rikka a chess board of size n×m .

As we all know, on a chess board, every cell is either black or white and every two cells that share a side have different colors.

Rikka can choose any rectangle formed by board squares and perform an inversion, every white cell becomes black, and vice versa.

Rikka wants to turn all cells into the same color, please tell Rikka the minimal number of inversions she need to achieve her goal.
 

Input
The first line contains a number T(T10) ——The number of the testcases.

Each testcase contains two numbers n,m(n109,m109) .
 

Output
For each testcase, print a single number which represents the answer.
 

Sample Input
  
  
3 1 2 2 2 3 3
 

Sample Output
  
  
1 2 2
 

Source
解题思路:
题目很好理解,就是有一个n*n的棋盘其中黑白方块相同颜色的是不会相邻的,每次我们都可以制定一个任意大小的矩形,将其中的颜色反转,问最小通过多少步可以将整个棋盘反转成同一种颜色。
很好理解先将2.4.6.8...........行反转,再将2.4.6.8..........反转就是最小步骤。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int  main()
{
    int t,a,b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&a,&b);
        int wc,wcnm;
        wc=a/2;
        wcnm=b/2;
        printf("%d\n",wc+wcnm);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值