POJ 3268-Silver Cow Party【正向+反向最短路】

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17121 Accepted: 7815

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source

解题思路:

题目大意就是有n头牛m条路,x最为目的地问在这个有向途中,回去再回来,最短路的情况下的花费,最小话费取厥于,最大的哪一个,将x这位出发点。正向和反向建图。

记住是有向图

#include<stdio.h>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int mapz[1100][1100];
int mapf[1100][1100];
int disz[1100],disf[1100];
bool vis[1100];
int n,m,x;
void PP1(int x)
{
	int i,j;
	for(i=1;i<=n;i++)
	{
		disz[i]=mapz[x][i];
	}
	vis[x]=true;
	disz[x]=0;
	for(i=0;i<n-1;i++)
	{
		int pos=x,min=INF;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&disz[j]<min)
			{
				pos=j;
				min=disz[j];
			}
		}
		vis[pos]=true;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&disz[j]>disz[pos]+mapz[pos][j])
			{
				disz[j]=disz[pos]+mapz[pos][j];
			}
		}
	}
}
void PP2(int x)
{
	int i,j;
	for(i=1;i<=n;i++)
	{
		disf[i]=mapf[x][i];
	}
	vis[x]=true;
	disf[x]=0;
	for(i=0;i<n-1;i++)
	{
		int pos=x,min=INF;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&disf[j]<min)
			{
				pos=j;
				min=disf[j];
			}
		}
		vis[pos]=true;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&disf[j]>disf[pos]+mapf[pos][j])
			{
				disf[j]=disf[pos]+mapf[pos][j];
			}
		}
	}
}

int main()
{
	while(scanf("%d%d%d",&n,&m,&x)!=EOF)
	{
		int i,j;
		memset(mapz,INF,sizeof(mapz));
		memset(mapf,INF,sizeof(mapf));
		for(i=0;i<m;i++)
		{
			int xx,yy,tt;
			scanf("%d%d%d",&xx,&yy,&tt);
			mapz[xx][yy]=min(mapz[xx][yy],tt);
			mapf[yy][xx]=min(mapf[yy][xx],tt);
		}
		memset(vis,false,sizeof(vis));
		PP1(x);
		memset(vis,false,sizeof(vis));
		PP2(x);
		int ans=-1;
		for(i=1;i<=n;i++)
		{
			ans=max(ans,disz[i]+disf[i]);
		}
		printf("%d\n",ans);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值