Sort it

Sort it

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
输入
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
输出
For each case, output the minimum times need to sort it in ascending order on a single line.
样例输入
3
1 2 3
4 
4 3 2 1 
样例输出
0
6

import java.util.Scanner;  
  
  
public class Main {  
  
    public static void main(String[] args) {  
        Scanner scanner=new Scanner(System.in);
        while(scanner.hasNext())
        {
        	int number=scanner.nextInt();
        	int arr[]=new int[number];
        	int count=0;
        	for(int i=0;i<number;i++)
        	{
        		arr[i]=scanner.nextInt();
        	}
        	for(int i=0;i<number;i++)
        	{
        		for(int j=i+1;j<number;j++)
        		{
        			if(arr[i]>arr[j])
        			{
        				count++;
        			}
        		}
        	}
        	System.out.println(count);
        }
    }  
  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值