05-树8 File Transfer

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2N104), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2

where I stands for inputting a connection between c1 and c2; or

C c1 c2

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

no
no
yes
There are 2 components.

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

no
no
yes
yes
The network is connected.

#include<stdio.h>
#include<stdlib.h>
#define MaxSize 100000
typedef int node;

typedef struct Node {
	node *a;
}Nodes,*qNode;

typedef qNode QNode;

//建树
void Create(QNode *q,int length) {
	*q = (Nodes*)malloc(sizeof(Nodes));
	(*q)->a = (node*)malloc(sizeof(node)*(length+1));
	for (int i = 0; i < length + 1; i++) {
		(*q)->a[i] = -1;
	}
}

//寻找集合
int Find(QNode q,int A) {
	while (q->a[A]>-1)
	{
		A = q->a[A];
	}
	return A;
}

//判断是否在一个集合
void Look(QNode q, int A, int B) {
	if (Find(q, A) == Find(q, B)) {
		printf("yes\n");
	}
	else {
		printf("no\n");
	}
}

//建立连接
void Link(QNode *q, int A, int B) {
	A = Find(*q, A);
	B = Find(*q, B);
	int temp = 0;
	if (A != B) {
		if ((*q)->a[A] < (*q)->a[B]) {
			temp = (*q)->a[A] + (*q)->a[B];
			(*q)->a[B] = A;
			(*q)->a[A] = temp;
		}
		else
		{
			temp= (*q)->a[B] + (*q)->a[A];
			(*q)->a[A] = B;
			(*q)->a[B] = temp;
		}
	}
}

//查看是否全连通
void LookAll(QNode q,int length) {
	int flag = 0;
	for (int i = 1; i < length + 1; i++) {
		if (q->a[i] < 0) {
			flag++;
		}
	}
	if (flag == 1) {
		printf("The network is connected.");
	}
	else {
		printf("There are %d components.",flag);
	}
}

int main()
{
	int n = 0;
	QNode q = NULL;
	scanf("%d\n", &n);
	Create(&q,n);
	int N = 1,A,B;
	char info;
	
	do{
		scanf("%c", &info);
		switch (info)
		{
		case 'C':
			scanf("%d %d\n", &A, &B);
			Look(q, A, B);
			break;
		case 'I':
			scanf("%d %d\n", &A, &B);
			Link(&q, A, B);
			break;
		case 'S':
			LookAll(q, n); 
			N = 0;
			break;
		default:
			break;
		}
	}while (N==1);

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值