PAT甲级 1003 Emergency

113 篇文章 9 订阅
110 篇文章 12 订阅

参考链接:点击打开链接

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.\ All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output

2 4

题目大意:n个城市m条路,每个城市有救援小组,所有的边的边权已知。给定起点和终点,求从起点到终点的最短路径条数以及最短路径上的救援小组数目之和。如果有多条就输出点权(城市救援小组数目)最大的那个~
分析:用一遍dijkstra算法。救援小组个数相当于点权,用Dijkstra求边权最小的最短路径的条数,以及这些最短路径中点权最大的值~
dis[i]:从出发点到i结点最短路径的路径长度
num[i]:从出发点到i结点最短路径的条数
w[i]:从出发点到i点救援队的数目之和

当判定dis[u] + e[u][v] < dis[v]的时候,不仅仅要更新dis[v],还要更新num[v] = num[u], w[v] = weight[v] + w[u]; 如果dis[u] + e[u][v] == dis[v],还要更新num[v] += num[u],而且判断一下是否权重w[v]更小,如果更小了就更新w[v] = weight[v] + w[u];

实现代码如下:

#include <iostream>
#include <algorithm>
using namespace std;

#define N 520
int edge[N][N],weight[N],disp[N],w[N],num[N];

bool visited[N] = {false};
const int inf = 999999;

int main(){
	
	fill(edge[0],edge[0] + N * N,inf);//注意这里要是N*N,要不然不是全部 
	fill(disp,disp + N,inf);
	
	int n,m,c1,c2;
	cin>>n>>m>>c1>>c2;
	
	for(int i=0;i < n;i++)
		cin>>weight[i];
	
	int a,b,c;
	for(int i=0;i < m;i++)
	{
		cin>>a>>b>>c;
		edge[a][b] = edge[b][a] = c; 	
	}
	
	disp[c1] = 0;
	num[c1] = 1;
	w[c1] = weight[c1];
	
	for(int i = 0;i < n;i++){
		
		int u = -1,min = inf;
		for(int j = 0;j < n;j++){
			if(visited[j] == false && disp[j] < min){//从未被标记为true的结点(即使算出了disp,但没变为true)中选一个最小的 
				u = j;
				min = disp[j];
			}		
		}
		
		if(u == -1)
			break;
		visited[u] = true;

		for(int v = 0;v < n;v++){
			
			if(visited[v] == false && edge[u][v] != inf){//计算与u有连接的点 
				if(disp[u] + edge[u][v] < disp[v]){
					disp[v] = disp[u] + edge[u][v];
					w[v] = w[u] + weight[v];
					num[v] = num[u];
				}	
				else if(disp[u] + edge[u][v] == disp[v]){
					num[v] = num[u] + num[v];
					if(w[v] < weight[v] + w[u])//有多条就输出点权(城市救援小组数目)最大的那个
						w[v] = weight[v] + w[u];

				}	
				
			}	
		}
	}
	cout<<num[c2]<<" "<<w[c2]<<endl;
	
	return 0;
}

运行结果如下:

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值