1077 Kuchiguse (20 分)
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:
-
Itai nyan~ (It hurts, nyan~)
-
Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai
.
Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai
题目大意:给定N给字符串,求他们的公共后缀,如果不存在公共后缀,就输出“nai”
注意:输入n后要跟着getchar(),否则getline(cin,str)读入一个换行符,str的结果是空字符串.
#include <iostream>
#include <cstdio>
#include <string>
#include <vector>
using namespace std;
int main()
{
int n;
cin>>n;
string str;
getchar();
getline(cin,str);
for(int i=1;i<n;i++){
string temp;
getline(cin,temp);
int str_index = str.length() - 1;
int temp_index = temp.length() - 1;
while(str[str_index] == temp[temp_index])
{
str_index--;
temp_index--;
}
int len = (str.length()-1) - str_index;
if(len == 0){
cout<<"nai";
return 0;
}
if(str.length() > len){//需要判断大于
str = str.substr(str_index+1);
}
}
cout<<str;
return 0;
}