PAT甲级 1101 Quick Sort (25 分) 快排

113 篇文章 9 订阅

1101 Quick Sort (25 分)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

分析:对原序列sort排序,逐个比较,当当前元素没有变化并且它左边的所有值的最大值都比它小的时候就可以认为它一定是主元(很容易证明正确性的,毕竟无论如何当前这个数要满足左边都比他小右边都比他大,那它的排名一定不会变)。

一个测试点格式错误。后来再最后加了最后一句printf(“\n”);才正确。(大部分测试用例结尾不输出换行符都可以通过。只有一个出现格式错误,是由于该测试点为特例,其结果为0。没有换行符其结果只有一行~) 

举例说明: 对于 9  7 11  14  23  5   这个输入,其排序后

                        5   7  9   11  14  23,看上去7位置不变,但是7也不是主元,因为原始序列中它左边的9比7大。

#include<iostream>
#include<vector>
#include<cstdio>
#include<algorithm> 
using namespace std;

int main(){
	int n;
	cin>>n;
	vector<int> vec(n),arr,res;
	for(int i=0;i<n;i++){
		scanf("%d",&vec[i]);
	}
	arr = vec;
	sort(arr.begin(),arr.end());
	int maxnum = -999999;
	for(int i=0;i<n;i++){
		if(vec[i] == arr[i] && arr[i] > maxnum)
			res.push_back(arr[i]);
		if(vec[i] > maxnum)
			maxnum = vec[i];
	}
	
	printf("%d\n",res.size());
	for(int i=0;i<res.size();i++)
		printf("%d%s",res[i],i!=res.size()-1?" ":"");
	printf("\n");
	return 0;
} } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值