PAT甲级 1102 Invert a Binary Tree (25 分)树的遍历(bfs+dfs)

113 篇文章 9 订阅
12 篇文章 0 订阅

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

解析: 输入一棵二叉树,要求反转二叉树,并且输出反转二叉树的层次遍历与中序遍历。那么在输入数据构造树的过程中就可以左右结点交换存储,完成反转。接着利用bfs+dfs即可完成要求。我在做这题时很顺利解决,但是提交时提示格式错误,后来发现是中序遍历后多了一个空格,改正后直接AC了。 

#include<iostream>
#include<vector>
#include<queue>
#include<cstdio>
using namespace std;

vector<vector<int>> e;
int n;

void bfs(int node){
	queue<int> que;
	que.push(node);
	int cnt = 0;
	while(!que.empty()){
		int v = que.front();
		que.pop();
		cnt++;
		printf("%d%s",v,cnt!=n?" ":"");
		for(int i=0;i<e[v].size();i++){
			if(e[v][i] != n)
				que.push(e[v][i]);
		}
	}	
}

void inorder(vector<int> &in,int node){
	if(e[node][0] != n) inorder(in,e[node][0]);
	in.push_back(node); 
	if(e[node][1] != n) inorder(in,e[node][1]);		
}

int main(){
	cin>>n;
	e.resize(n);
	char a,b;
	for(int i=0;i<n;i++){
		cin>>a>>b;
		if(b != '-')//反过来存储获得BT 
			e[i].push_back(b-'0');
		else
			e[i].push_back(n);
		if(a != '-')
			e[i].push_back(a-'0');
		else
			e[i].push_back(n);
	}
	vector<int> temp(n+1,0);
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<e[i].size();j++)
			temp[e[i][j]] = 1;
	}
	int root = -1;
	for(int i=0;i<n;i++)
		if(temp[i] == 0)
			root = i;
	bfs(root);
	printf("\n");
	vector<int> in;
	inorder(in,root);
	for(int i=0;i<in.size();i++)
		printf("%d%s",in[i],i!=in.size()-1?" ":"");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值