PAT甲级 1107 Social Clusters (30 分)并查集

113 篇文章 9 订阅
4 篇文章 0 订阅

1107 Social Clusters (30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

解题思路: 该题简单,主要是利用并查集将人分成几个组。最后输出组数与每个组对应的人数即可。

#include <iostream>
#include <cstdio>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;

vector<int> f(10001);

int find(int node){
	int x = node;
	while(f[x]!=x)
		x = f[x];
	int i = node,temp;
	while(f[i]!=x){//剪枝 
		temp = f[i];
		f[i] = x;
		i = temp;
	}
	return x;
}

void unio(int a,int b){
	int fa = find(a),fb = find(b);
	if(fa != fb)
		f[fa] = fb;
} 

bool cmp(int a,int b){
	return a > b;
}

int main(){
	int n,a,b;
	cin>>n;
	for(int i=1;i<10001;i++)
		f[i] = i;
	vector<int> person[n],vec,vst(10001,0),ans;
	for(int i=0;i<n;i++){
		scanf("%d: ",&a);
		for(int j=0;j<a;j++){
			cin>>b;
			person[i].push_back(b);
			vec.push_back(b);
		}	
		for(int j=0;j<person[i].size()-1;j++)
			unio(person[i][j],person[i][j+1]);
	}
	for(int i=0;i<vec.size();i++)
		find(vec[i]);
	int cnt = 0;
	map<int,int> mp;
	for(int i=0;i<vec.size();i++){
		if(vst[f[vec[i]]] == 0){
			vst[f[vec[i]]] = 1;
			cnt++;
		}
	}
	cout<<cnt<<endl;
	for(int i=0;i<n;i++){
		int index = f[person[i][0]];//找到每个人对应的小组 
		mp[index]++;//记录小组对应的人数 
	}
	for(auto it:mp)
		ans.push_back(it.second);
	sort(ans.begin(),ans.end(),cmp);
	for(int i=0;i<ans.size();i++)
		printf("%d%s",ans[i],i!=ans.size()-1?" ":"");		
		
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值