1107 Social Clusters (30 分)——甲级(并查集)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki : h​i​​ [1] h​i[2] … h​i[Ki]

where K​i(>0) is the number of hobbies, and h​i​​ [j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1

题目大意:给出一个社交网络的人数。对于每个人,给出它拥有的爱好的编号。如果两个人有相同的爱好,则他们属于一个社交圈。计算社交圈的个数以及每个社交圈的人数。

思路:不妨假设人的编号从1~n,这样可以方便后序的并查集操作。定义一个h[x]数组,表示编号为x的爱好属于哪一个人,初始化为0。对于每个人i,如果这个爱好之前不属于任何人,则h[x]置为i;否则,将这个人与h[x]并。最后扫描father[ ]数组,记录答案。

代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
int father[1001], h[1001];
int Find(int x)/* 非递归压缩路径 */
{
    int node = x;
    while(father[node] >= 0) node = father[node];
    while(x != node)
    {
        int temp = x;
        father[x] = node;
        x = father[temp];
    }
    return node;
}
void Merge(int a, int b)
{
    int r1 = Find(a);
    int r2 = Find(b);
    if(r1 != r2)/* 将小集合并到大集合中 */
    {
        if(father[r1] < father[r2])
        {
            father[r1] += father[r2];
            father[r2] = r1;
        }
        else
        {
            father[r2] += father[r1];
            father[r1] = r2;
        }
    }
}
bool cmp(int a, int b)
{
    return a>b;
}
int main()
{
    int n, i, k;
    scanf("%d", &n);
    for(i=1; i<=n; i++)
    {
        father[i] = -1;
        scanf("%d:", &k);
        while(k--)
        {
            int x;
            scanf("%d", &x);
            if(h[x] == 0) h[x] = i;/* 没有出现过,则该人为father */
            else Merge(i, h[x]);/* 出现过,则h[x]为father,将i并到h[x]所在社交圈中去 */
        }
    }
    vector<int>v;
    for(i=1; i<=n; i++)
        if(father[i] < 0) v.push_back(-father[i]);
    sort(v.begin(), v.end(), cmp);
    printf("%d\n", v.size());
    for(i=0; i<v.size(); i++)
        printf("%d%c", v[i], i==v.size()-1?'\n':' ');
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值