时间类的静态成员计数

Description
封装一个时间类Time,用于时间处理的相关功能,支持以下操作:
1. Time::Time()无参构造方法。
2. Time::Time(int,int,int)构造方法:传递时分秒的三个参数构造对象。
3. Time::Time(const T&)拷贝构造方法。
4. 对象整体读写方法:
Time::setTime(int,int,int)方法:传递时分秒三个参数修改Time对象的时分秒数。该方法返回修改后的对象。
Time::setTime(const T&)方法:传递一个参数修改Time对象的时分秒数。该方法返回修改后的对象。
Time::getTime()方法:返回对象自身的引用。其实,t.getTime()即t。
仅在Time类中的Time::getTime()方法实在是多余,在组合或者继承关系时才会有机会用到。
5. Time::showTime()方法:输出“hh:mm:ss”,不足两位的要前面补0。如果对象不是合法的时间,则输出“Time error”。
6. 静态成员方法:
Time::getNumber()方法:返回程序中已创建的Time对象总数。
Time::displayNumber()方法:输出程序中已创建的Time对象总数。
注意:在用Time对象传递参数时应传对象的引用而不是直接传对象,返回对象时同样返回引用,以免产生多余的对象拷贝。多余的拷贝构造会引起对象计数的错误。
你设计一个时间类Time,使得main()函数能够正确运行。
函数调用格式见append.cc。
append.cc中已给出main()函数。main()函数内容稍微繁复,仅为测试对象的各种调用情况。
Input
输入为多行,每行为一组测试数据,每组3个整数:hh,mm,ss,分别表示时、分、秒,其值都在int范围内。
Output
开始部分为由main()函数产生的固定输出,用于测试对象的某些方法的调用情况。输出“Test data output :”之后为测试数据对应的输出:
每组测试数据对应一组输出“hh:mm:ss”,不足两位的输出需要前面补0。如果输入的时间不合法,则输出“Time error”。格式见sample。
最后一行输出一个整数n,表示有n组测试数据输入。
Sample Input
0 0 1
0 59 59
1 1 60
23 0 0
23 59 59
24 1 0
Sample Output
Static member test output :
Now, There is 0 object of Time.
Now, There is 1 object of Time.
There was a call to the copy constructor : 0,0,0
Now, There is 2 object of Time.
Now, There is 3 object of Time.
There was a call to the copy constructor : 1,2,3
Now, There is 4 object of Time.

Test data output :
00:00:01
00:59:59
Time error
23:00:00
23:59:59
Time error
6

#include <bits/stdc++.h>
#define while(cinhourminutesecond) while(scanf("%d%d%d",&hour,&minute,&second)!=EOF)

using namespace std;
class Time{
private:
    int h;
    int m;
    int s;
    static int sum;
public:
    Time():h(0),m(0),s(0){sum++;}
    Time(int h_,int m_,int s_):h(h_),m(m_),s(s_){sum++;}
    Time(const Time &t):h(t.h),m(t.m),s(t.s){sum++;printf("There was a call to the copy constructor : %d,%d,%d\n",h,m,s);}
    ~Time(){sum--;}
    int hour()  {return h;}
    int minute(){return m;}
    int second(){return s;}
    void hour(int h_){h=h_;}
    void minute(int m_){m=m_;}
    void second(int s_){s=s_;}
    Time& setTime(int h_,int m_,int s_)   {h=h_;m=m_;s=s_;sum++;return *this;}
    Time& setTime(const Time& t)          {h=t.h;m=t.m;s=t.s;sum++;printf("There was a call to the copy constructor : %d,%d,%d\n",h,m,s);return *this;}
    Time& getTime(){return *this;}
//    Time& inputTime(){scanf("%d %d %d",&h,&m,&s);return *this;}
    void showTime()const
    {
        if(h<0||h>=24||m<0||m>=60||s<0||s>=60)
            printf("Time error\n");
        else
            printf("%.2d:%.2d:%.2d\n",h,m,s);
    }
    static int getNumber()      {return sum;}
    static void displayNumber() {printf("Now, There is %d object of Time.\n",sum);}
};
int Time::sum=0;
int main()
{
    cout<<"Static member test output :"<<endl;
    Time::displayNumber();
    Time t;
    t.displayNumber();
    Time tt(t);
    tt.displayNumber();
    Time ttt(1, 2, 3);
    ttt.displayNumber();
    Time tttt(ttt.getTime());
    tttt.displayNumber();
    int non_cases = Time::getNumber();

    cout<<"\nTest data output :"<<endl;
    int hour, minute, second;
    while(cin>>hour>>minute>>second)
    {
        Time t;
        t.setTime(hour, minute, second).showTime();
    }
    cout<<t.getNumber() - non_cases<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值