Problem E: 时间类的静态成员计数

Problem E: 时间类的静态成员计数

Time Limit: 4 Sec   Memory Limit: 128 MB
Submit: 2009   Solved: 1451
[ Submit][ Status][ Web Board]

Description

封装一个时间类Time,用于时间处理的相关功能,支持以下操作:
1. Time::Time()无参构造方法。
2. Time::Time(int,int,int)构造方法:传递时分秒的三个参数构造对象。
3. Time::Time(const T&)拷贝构造方法。
4. 对象整体读写方法:
   Time::setTime(int,int,int)方法:传递时分秒三个参数修改Time对象的时分秒数。该方法返回修改后的对象。
   Time::setTime(const T&)方法:传递一个参数修改Time对象的时分秒数。该方法返回修改后的对象。
   Time::getTime()方法:返回对象自身的引用。其实,t.getTime()即t。
   仅在Time类中的Time::getTime()方法实在是多余,在组合或者继承关系时才会有机会用到。
5. Time::showTime()方法:输出“hh:mm:ss”,不足两位的要前面补0。如果对象不是合法的时间,则输出“Time error”。
6. 静态成员方法:
   Time::getNumber()方法:返回程序中已创建的Time对象总数。
   Time::displayNumber()方法:输出程序中已创建的Time对象总数。
注意:在用Time对象传递参数时应传对象的引用而不是直接传对象,返回对象时同样返回引用,以免产生多余的对象拷贝。多余的拷贝构造会引起对象计数的错误。
你设计一个时间类Time,使得main()函数能够正确运行。
函数调用格式见append.cc。
append.cc中已给出main()函数。main()函数内容稍微繁复,仅为测试对象的各种调用情况。

Input

输入为多行,每行为一组测试数据,每组3个整数:hh,mm,ss,分别表示时、分、秒,其值都在int范围内。

Output

开始部分为由main()函数产生的固定输出,用于测试对象的某些方法的调用情况。输出“Test data output :”之后为测试数据对应的输出:
每组测试数据对应一组输出“hh:mm:ss”,不足两位的输出需要前面补0。如果输入的时间不合法,则输出“Time error”。格式见sample。
最后一行输出一个整数n,表示有n组测试数据输入。

Sample Input

0 0 10 59 591 1 6023 0 023 59 5924 1 0

Sample Output

Static member test output :Now, There is 0 object of Time.Now, There is 1 object of Time.There was a call to the copy constructor : 0,0,0Now, There is 2 object of Time.Now, There is 3 object of Time.There was a call to the copy constructor : 1,2,3Now, There is 4 object of Time.Test data output :00:00:0100:59:59Time error23:00:0023:59:59Time error6

HINT

Append Code

#include<iostream>
#include <iomanip>
using namespace std;
class Time
{
private:
    int h,m,s;
   static int sum;
public:
    Time():h(0),m(0),s(0){sum++;}
    Time(int a,int b,int c):h(a),m(b),s(c){sum++;}
    Time(const Time &t):h(t.h),m(t.m),s(t.s){sum++;cout<<"There was a call to the copy constructor : "<<h<<","<<m<<","<<s<<endl;}
    ~Time(){}
    int hour(){return h;}
    int minute(){return m;}
    int second(){return s;}
    void hour(int a){h = a;}
    void minute(int b){m = b;}
    void second(int c){s = c;}

    Time& setTime(int a,int b,int c){h = a;m = b;s = c;return *this;}
    Time& setTime(const Time&t){h = t.h;m = t.m;s = t.s;return *this;}
    Time& getTime(){return *this;}///
    Time& inputTime(){cin>>h>>m>>s;return *this;}

    void showTime()
    {
        if(h*3600+m*60+s>=24*3600||m>59||s>59||h<0||s<0||m<0)
            cout<<"Time error"<<endl;
       else cout<<setw(2)<<setfill('0')<<h<<":"<<setw(2)<<setfill('0')<<m<<":"<<setw(2)<<setfill('0')<<s<<endl;
    }
   static int getNumber()
    {
        return sum;
    }
    static void displayNumber()
    {
        cout<<"Now, There is "<<sum<<" object of Time."<<endl;
    }
};
int Time::sum = 0;
int main()
{
    cout<<"Static member test output :"<<endl;
    Time::displayNumber();
    Time t;
    t.displayNumber();
    Time tt(t);
    tt.displayNumber();
    Time ttt(1, 2, 3);
    ttt.displayNumber();
    Time tttt(ttt.getTime());
    tttt.displayNumber();
    int non_cases = Time::getNumber();

    cout<<"\nTest data output :"<<endl;
    int hour, minute, second;
    while(cin>>hour>>minute>>second)
    {
        Time t;
        t.setTime(hour, minute, second).showTime();
    }
    cout<<t.getNumber() - non_cases<<endl;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值