HD 1513 Palindrome 【LCS】

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4040    Accepted Submission(s): 1370


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
  
  
5 Ab3bd
 

Sample Output
  
  
2
题意:输入n个字母,求添加几个字母能变成一个回文字母。
思路:本题采用把原来的字母倒序之后求两个字符数组的最长公共子序列,之后再用n减去最长公共子序列,就是所加的字母数。
注意:本体要求的是不超过5000,所以要用的滚动数组。否则会要超内存。对于滚动数组,我也有点不太明白。-.-
AC代码
#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b
char s1[5005],s2[5005];
int vis[2][5005];
int main()
{
	int k,m,i,j;
    while(scanf("%d",&k)!=EOF)
    {
    	scanf("%s",s1);
    	for(i=k-1,j=0;i>=0;i--,j++)
    	s2[i]=s1[j];
    	//s2[k-1]='\0'; 
    	memset(vis,0,sizeof(vis));
    	for(i=1;i<=k;i++)
    	{
    		for(j=1;j<=k;j++)
    		{
    			int x=i%2;
				int y=1-x;
    			if(s1[i-1]==s2[j-1])
    			{
    				vis[x][j]=vis[y][j-1]+1;
				}
				else
				{
					vis[x][j]=max(vis[y][j],vis[x][j-1]);
				}
			}
		}
		printf("%d\n",k-vis[k%2][k]);
	}	
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值