hdoj--5606--tree(并查集)

tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 557    Accepted Submission(s): 271


Problem Description
There is a tree(the tree is a connected graph which contains n points and n1 edges),the points are labeled from 1 to n ,which edge has a weight from 0 to 1,for every point i[1,n] ,you should find the number of the points which are closest to it,the clostest points can contain i itself.
 

Input
the first line contains a number T,means T test cases.

for each test case,the first line is a nubmer n ,means the number of the points,next n-1 lines,each line contains three numbers u,v,w ,which shows an edge and its weight.

T50,n105,u,v[1,n],w[0,1]
 

Output
for each test case,you need to print the answer to each point.

in consideration of the large output,imagine ansi is the answer to point i ,you only need to output, ans1 xor ans2 xor ans3.. ansn .
 

Sample Input
  
  
1 3 1 2 0 2 3 1
 

Sample Output
  
  
1 in the sample. $ans_1=2$ $ans_2=2$ $ans_3=1$ $2~xor~2~xor~1=1$,so you need to output 1.
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5609  5608  5607  5605  5604 
借鉴大神的思路,太牛!
递归一直出错,最后乖乖用了循环,是不是压缩路径的方式不对啊,
#include<stdio.h>
#include<string.h>
int rank[100100];
int pre[100100];
void init()
{
	for(int i=0;i<100100;i++)
	pre[i]=i;
}
//int find(int x)
//{
//	return pre[x]==x?x:pre[x]=find(pre[x]);
//}
int find(int p)
{
	int child=p;
	while(p!=pre[p])
	p=pre[p];
	while(child!=p)
	{
		int t=pre[child];
		pre[child]=p;
		child=t;
	}
	return p;
}
void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fy!=fx)
	pre[fx]=fy;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		memset(rank,0,sizeof(rank));
		init();
		int a,b,c;
		scanf("%d",&n);
		for(int i=1;i<n;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(c==0)
			join(a,b);
		}
		for(int i=1;i<=n;i++)
		{
			if(pre[i]==i)
				rank[i]++;
			else
				rank[find(i)]++;
		}
		int ans=0;
		for(int i=1;i<=n;i++)
		ans^=(rank[find(i)]);
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值