HDOJ 5606 tree【并查集建图】

tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 452    Accepted Submission(s): 225


Problem Description
There is a tree(the tree is a connected graph which contains n points and n1 edges),the points are labeled from 1 to n ,which edge has a weight from 0 to 1,for every point i[1,n] ,you should find the number of the points which are closest to it,the clostest points can contain i itself.
 

Input
the first line contains a number T,means T test cases.

for each test case,the first line is a nubmer n ,means the number of the points,next n-1 lines,each line contains three numbers u,v,w ,which shows an edge and its weight.

T50,n105,u,v[1,n],w[0,1]
 

Output
for each test case,you need to print the answer to each point.

in consideration of the large output,imagine ansi is the answer to point i ,you only need to output, ans1 xor ans2 xor ans3.. ansn .
 

Sample Input
  
  
1 3 1 2 0 2 3 1
 

Sample Output
  
  
1 in the sample. $ans_1=2$ $ans_2=2$ $ans_3=1$ $2~xor~2~xor~1=1$,so you need to output 1.


恩,后来队友给讲的思想,就是权值为0的建图,然后在一个连通图中的节点个数就是对于图中所有节点来说离它最近的节点个数,然后逐个异或就好


#include<cstdio>
#include<cstring>
#define maxn 100010
using namespace std;
int pre[maxn],mark[maxn];
int find(int x)
{
    return x==pre[x]?x:pre[x]=find(pre[x]);
}
void join(int a,int b)
{
    int fa=find(a);
    int fb=find(b);
    if(fa!=fb)
        pre[fa]=fb;
}
int main()
{
    int t,n,a,b,v;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;++i)
            pre[i]=i;
        for(int i=1;i<n;++i)
        {
            scanf("%d%d%d",&a,&b,&v);
            if(!v)
                join(a,b);
        }
        memset(mark,0,sizeof(mark));
        for(int i=1;i<=n;++i)
            mark[find(i)]++;
        int sum=0;
        for(int i=1;i<=n;++i)
        {
            if(mark[i])
            {
                int tem=mark[i];
                while(tem--)
                    sum=sum^mark[i];
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值