poj--2236--Wireless Network(并查集)

Wireless Network
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 20759 Accepted: 8719

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

题意:给了n台电脑,每台电脑都出了故障,并且在电脑修复后,网络中电脑只能与距离自己d米以内的电脑联系,现在给出每个电脑的坐标,以及若干组操作,
O P表示修复P电脑,S P Q 表示查询P Q是否可以联系,可以联系的话输出SUCCESS否则输出FAIL
在每一次修复电脑之后我们都判断一次该电脑与已修复的电脑是否可以联系,当然,这是在距离在d以内的情况下,可以的话就合并,同时标记该电脑已经修复
查询时只需要判断是否在一棵树上就行,但是不知道为什么使用sqrt时总是编译错误
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int pre[1010],n,d;
bool flog[1010];
struct node
{
	int x,y;
}p[10010];
int find(int x)
{
	while(x!=pre[x])
	x=pre[x];
	return pre[x];
}
double dis(node s1,node s2)
{
	return  (s1.x-s2.x)*(s1.x-s2.x)+(s1.y-s2.y)*(s1.y-s2.y);
}
int main()
{
	while(scanf("%d%d",&n,&d)!=EOF)
	{
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&p[i].x,&p[i].y);
			pre[i]=i;
		}
		char op[2];
		int  u,v;
		memset(flog,false,sizeof(flog));
		while(scanf("%s",op)!=EOF)
		{
			if(op[0]=='O')
			{
				scanf("%d",&u);
				if(flog[u]) continue;
				flog[u]=true;
				for(int i=1;i<=n;i++)
				{
					int fi=find(i);
					int fu=find(u);
					if(flog[i]&&dis(p[i],p[u])<=d*d)
					{
						pre[fi]=fu;
					}
				}
			}
			else
			{
				scanf("%d%d",&u,&v);
				int fu=find(u);
				int fv=find(v);
				if(fu!=fv)
				printf("FAIL\n");
				else
				printf("SUCCESS\n");
			}
		}
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值