hdoj--5671--Matrix(思维)



Matrix

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1027    Accepted Submission(s): 427


Problem Description
There is a matrix   M  that has   n  rows and   m  columns   (1n1000,1m1000) .Then we perform   q(1q100,000)  operations:

1 x y: Swap row x and row y   (1x,yn) ;

2 x y: Swap column x and column y   (1x,ym) ;

3 x y: Add y to all elements in row x   (1xn,1y10,000) ;

4 x y: Add y to all elements in column x   (1xm,1y10,000) ;
 

Input
There are multiple test cases. The first line of input contains an integer   T(1T20)  indicating the number of test cases. For each test case:

The first line contains three integers   n ,   m  and   q .
The following   n  lines describe the matrix M. (1Mi,j10,000)  for all   (1in,1jm) .
The following   q  lines contains three integers   a(1a4) ,   x  and   y .
 

Output
For each test case, output the matrix   M  after all   q  operations.
 

Sample Input
  
  
2 3 4 2 1 2 3 4 2 3 4 5 3 4 5 6 1 1 2 3 1 10 2 2 2 1 10 10 1 1 1 2 2 1 2
 

Sample Output
  
  
12 13 14 15 1 2 3 4 3 4 5 6 1 10 10 1
题意:n*m的矩阵,进行s次操作,op,x,y,op==1,2表示交换行,列,op==3,4表示行+y,列+y,输出最后产生的矩阵
通过构建新图减少运算的次数
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define MAXN 10100
int r[MAXN],c[MAXN],addr[MAXN],addc[MAXN],map[1010][1010];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m,s;
		scanf("%d%d%d",&n,&m,&s);
		memset(map,0,sizeof(map));
		for(int i=1;i<=n;i++)
			for(int j=1;j<=m;j++)
				scanf("%d",&map[i][j]);
		for(int i=1;i<=n;i++)
		{
			r[i]=i;
			addr[i]=0;
		}
		for(int i=1;i<=m;i++)
		c[i]=i,addc[i]=0;
		int op,x,y;
		for(int i=0;i<s;i++)
		{
			scanf("%d%d%d",&op,&x,&y);
			if(op==1)
				swap(r[x],r[y]);
			else if(op==2)
				swap(c[x],c[y]);
			else if(op==3)
				addr[r[x]]+=y;
			else if(op==4)
				addc[c[x]]+=y;
		}
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				if(j>1) 
				printf(" ");
				printf("%d",map[r[i]][c[j]]+addr[r[i]]+addc[c[j]]);
			}
			printf("\n");
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值