PTA乙级1038

第五条1038

本题要求读入 N 名学生的成绩,将获得某一给定分数的学生人数输出。

输入格式:

输入在第 1 行给出不超过 10
​5
​​ 的正整数 N,即学生总人数。随后一行给出 N 名学生的百分制整数成绩,中间以空格分隔。最后一行给出要查询的分数个数 K(不超过 N 的正整数),随后是 K 个分数,中间以空格分隔。

输出格式:

在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。

输入样例:

10
60 75 90 55 75 99 82 90 75 50
3 75 90 88

输出样例:

3 2 0

思路:用循环判断计数
代码:

package test1;

import java.io.BufferedReader;
import java.io.InputStreamReader;

public class PTA1038 {

    public static void main(String[] args) throws Exception {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        int[] score = new int[101];
        int N = Integer.parseInt(br.readLine());

        String[] in = br.readLine().split(" ");

        for (int i = 0; i < N; i++) {
            score[Integer.parseInt(in[i])]++;
        }
        String[] s = br.readLine().split(" ");
        int k = Integer.parseInt(s[0]);
        for (int i = 0; i < k - 1; i++) {
            System.out.print(score[Integer.parseInt(s[i + 1])] + " ");
        }
        System.out.print(score[Integer.parseInt(s[s.length - 1])]);

    }

}

输出结果:
10
15 8 94 15 55 55 64 55 64 66
4 15 8 55 100
2 1 3 0

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值