HDu4864

Task

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5447    Accepted Submission(s): 1425


Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases.
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
  
  
1 2 100 3 100 2 100 1
 



Sample Output
1 50004
//用任务匹配机器,首先,机器和任务都他吗按大小排列,
//再从第一个机器开始寻找所有机器的时间大鱼等于这个任务的时间,
//用leve统计每个任务出现的次数,再从等级里面找最接近这个等级的任务
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define N 100005
using namespace std;

struct node
{
    int x,y;
};
bool cmp(node a,node b)
{
    if(a.x==b.x)
        return a.y>b.y;
    return a.x>b.x;
}
node mach[N],task[N];
int main()
{
    __int64 sum;
    int i,j,ans,leve[105];
    int n,m;
    while(scanf("%d%d",&n,&m)>0)
    {
        memset(leve,0,sizeof(leve));
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&mach[i].x,&mach[i].y);
        }
        for(i=0; i<m; i++)
        {
            scanf("%d%d",&task[i].x,&task[i].y);
        }
        sort(mach,mach+n,cmp);
        sort(task,task+m,cmp);
        sum=0,ans=0;
        j=0;
        for(int i=0;i<m;i++)
        {
            while(j<n&&mach[j].x>=task[i].x)
            leve[mach[j++].y]++;
            for(int lev=task[i].y; lev<=100;lev++)
            if(leve[lev])
            {
                ans++;
                sum+=500*task[i].x+2*task[i].y;
                leve[lev]--;
                break;
            }
        }
        printf("%d %I64d\n",ans,sum);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值