题目
链接https://www.patest.cn/contests/pat-b-practise/1042
请编写程序,找出一段给定文字中出现最频繁的那个英文字母。
输入格式:
输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。
输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。
输入样例:
This is a simple TEST. There ARE numbers and other symbols 1&2&3...........
输出样例:
e 7
思路
字母的存储用对应的ascii码存储
代码
#include <iostream>
#include <vector>
#include <cstring>
#include <string>
#include <cmath>
#include<iomanip>
#include <queue>
#include <set>
using namespace std;
int main()
{
//freopen("in.txt" , "r" , stdin);//字符串查找 转化为对其asacII码的存储
int a[256];
memset(a,0,sizeof(a));
char b[1001];
gets(b);
int len=strlen(b);
for(int i=0;i<len;i++)//大写转为小写
if(b[i]>='A'&&b[i]<='Z')
b[i]+=32;
char t;
int max=0;
for(int j=0;j<len;j++)
{
if(b[j]>='a'&&b[j]<='z')
{
a[int(b[j])]++;
if(a[int(b[j])]>max)
{
max=a[int(b[j])];
t=b[j];
}
if(a[int(b[j])]==max)
if(b[j]<t)
t=b[j];
}
}
cout<<t<<" "<<max<<endl;
return 0;
}