1017. A除以B

<p style="margin-top: 0px; margin-bottom: 1.5em; padding-top: 0px; padding-bottom: 0px; border: 0px; font-stretch: inherit; line-height: 13.8462px; font-family: 'Droid Sans', Verdana, 'Microsoft YaHei', Tahoma, sans-serif; vertical-align: baseline; color: rgb(51, 51, 51); background-color: rgb(250, 250, 250);">本题要求计算A/B,其中A是不超过1000位的正整数,B是1位正整数。你需要输出商数Q和余数R,使得A = B * Q + R成立。</p><p style="margin-top: 0px; margin-bottom: 1.5em; padding-top: 0px; padding-bottom: 0px; border: 0px; font-stretch: inherit; line-height: 13.8462px; font-family: 'Droid Sans', Verdana, 'Microsoft YaHei', Tahoma, sans-serif; vertical-align: baseline; color: rgb(51, 51, 51); background-color: rgb(250, 250, 250);"><strong>输入格式:</strong></p><p style="margin-top: 0px; margin-bottom: 1.5em; padding-top: 0px; padding-bottom: 0px; border: 0px; font-stretch: inherit; line-height: 13.8462px; font-family: 'Droid Sans', Verdana, 'Microsoft YaHei', Tahoma, sans-serif; vertical-align: baseline; color: rgb(51, 51, 51); background-color: rgb(250, 250, 250);">输入在1行中依次给出A和B,中间以1空格分隔。</p><p style="margin-top: 0px; margin-bottom: 1.5em; padding-top: 0px; padding-bottom: 0px; border: 0px; font-stretch: inherit; line-height: 13.8462px; font-family: 'Droid Sans', Verdana, 'Microsoft YaHei', Tahoma, sans-serif; vertical-align: baseline; color: rgb(51, 51, 51); background-color: rgb(250, 250, 250);"><strong>输出格式:</strong></p><p style="margin-top: 0px; margin-bottom: 1.5em; padding-top: 0px; padding-bottom: 0px; border: 0px; font-stretch: inherit; line-height: 13.8462px; font-family: 'Droid Sans', Verdana, 'Microsoft YaHei', Tahoma, sans-serif; vertical-align: baseline; color: rgb(51, 51, 51); background-color: rgb(250, 250, 250);">在1行中依次输出Q和R,中间以1空格分隔。</p><span style="color: rgb(51, 51, 51); font-family: 'Droid Sans', Verdana, 'Microsoft YaHei', Tahoma, sans-serif; line-height: 13.8462px; background-color: rgb(250, 250, 250);">输入样例:</span><pre style="margin-top: 1.5em; margin-bottom: 1.5em; padding: 0px; border: 0px; font-stretch: normal; line-height: 13.8462px; font-family: 'Droid Sans Mono', Consolas, 'Courier New', monospace; vertical-align: baseline; overflow: auto; color: rgb(51, 51, 51); background-color: rgb(250, 250, 250);">123456789050987654321 7
输出样例:
17636684150141093474 3

 
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String m = sc.next();
		int B = sc.nextInt();
		char[] ch = m.toCharArray();
		int c = ch.length;
		int[] in = new int[c];
		int n = 0;
		int R = 0;
		if(c>1){
			for (int i = 0; i < c; i++) {
				R = (ch[i] - 48) + n * 10;
				in[i] = R / B;
				n = R % B;
			}
		if (in[0] == 0) {
			for (int i = 1; i < c; i++) {
				System.out.print(in[i]);
			}
		} else {
			for (int i = 0; i < c; i++) {
				System.out.print(in[i]);
			}
		}
		}else{
			n = (ch[0]-48)%B;
			System.out.print((ch[0]-48)/B);
		}
		System.out.print(" " + n);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值