找工作笔试题目

1. 矩阵乘法计算量估算

描述:
矩阵乘法的运算量与矩阵乘法的顺序强相关。
例如:
A是一个50×10的矩阵,B是10×20的矩阵,C是20×5的矩阵
计算ABC有两种顺序:((AB)C)或者(A(BC)),前者需要计算15000次乘法,后者只需要3500次。
编写程序计算不同的计算顺序需要进行的乘法次数。
数据范围:矩阵个数:1\le n\le 15 \1≤n≤15 ,行列数:1<=row,col<=100,保证给出的字符串表示的计算顺序唯一。
进阶:时间复杂度:O(n)\O(n) ,空间复杂度:O(n)\O(n)

输入描述:
输入多行,先输入要计算乘法的矩阵个数n,每个矩阵的行数,列数,总共2n的数,最后输入要计算的法则
计算的法则为一个字符串,仅由左右括号和大写字母(‘A’~‘Z’)组成,保证括号是匹配的且输入合法!

输出描述:
输出需要进行的乘法次数

示例1

输入:
3
50 10
10 20
20 5
(A(BC))
输出:3500

AC:

#include <iostream>
#include <vector>
using namespace std;
 
int fun(vector<vector<int>> &group,string str)
{
    int count = 0;
    int a=str.at(0)-'A';
    for(int i=1;i<str.size();i++)
    {
        int b=str.at(i)-'A';
        count+=group[a][0]*group[a][1]*group[b][1];
        group[a][1]=group[b][1];
    }
    return count;
}
 
int main() {
    int N;
    while (cin >> N) 
    {
        vector<vector<int> >group(N,vector<int>(2,0));
        for(int i=0;i<N;i++)
        {
            for(int j=0;j<2;j++)
            {
                cin >> group[i][j];
            }
        }
        string str;
        cin >> str;
        int count = 0;
        while(str.find_last_of(")") != -1)
        {
            int index_l = str.find_last_of("(");
            string tmp_str;
            tmp_str.assign(str,index_l);
            int index_r = tmp_str.find_first_of(")");
            tmp_str.assign(tmp_str,1,index_r-1);
            count+=fun(group,tmp_str);
            tmp_str = tmp_str.at(0);
            str.erase(index_l,index_r+1);
            str.insert(index_l,tmp_str);
        }
        if(str.size()!=1)
        {
            count+=fun(group,str);
        }
        cout << count << endl;
    }
}

华为机试题

2. 简单计算器

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

Sample Input
1 + 2
4 + 2 * 5 - 7 / 11
0
Sample Output
3.00
13.36

AC:

#include<iostream>
#include<algorithm>
#include<stack>
#include<map>
#include<cstring>
using namespace std;
stack<double> num;
stack<char> op;
string s,s1;
map<char,int> h;
void eval()
{
	double b=num.top();
	num.pop();
	double a=num.top();
	num.pop();
	char p=op.top();
	op.pop();
	
	double r;
	if(p=='+') r=a+b;
	else if(p=='-') r=a-b;
	else if(p=='*') r=a*b;
	else if(p=='/') r=a/b;
	
	num.push(r);
}
int main()
{
	h['+']=1; h['-']=1;
	h['*']=2; h['/']=2;
	while(getline(cin,s1))
	{
		if(s1=="0") break;
			s.clear();
		for(int i=0;i<s1.size();i++)
		{
			if(s1[i]!=' ')
				s+=s1[i];	
		} 
		for(int i=0;i<s.size();i++)
		{
			if(isdigit(s[i]))
			{
				double sum=0;
				while(isdigit(s[i]))
				{
					sum=sum*10+(s[i]-'0');
					i++;
				}
				num.push(sum);
				i--;
			}
			else
			{
				while(op.size() && h[op.top()]>=h[s[i]]) eval();
				op.push(s[i]);
			}
			
		}
		while(op.size()) eval();
		printf("%.2lf\n",num.top());		
	}
	return 0;
}

原文链接:https://blog.csdn.net/weixin_52341477/article/details/118679542

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小猛笔记

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值