NJL

版本appium1.4.16解决需要手动安装AppiumSettings、Unlock、AndroidInputManager的问题

一、问题描述

新老版本的appium-desktop都存在部分机型需要手动安装AppiumSettings、Unlock、AndroidInputManager的问题,目前笔者在小米、vivo手机上碰到过这个问题,如果每次需要手动确认安装这些组件,基本上无法正常开展自动化。本篇博客是针对老版本的appium(版本号1.4.x),至于新版的appium-desktop(版本号1.6.x+)类似问题的解决方法,
请大家参阅:http://blog.csdn.net/hszxd479946/article/details/78900982
 

二、解决过程

找到这个文件:D:\njl\Appium\node_modules\appium\lib\devices\android\android.js
笔者appium安装在D盘,这个大家自己看看自己的appium具体装在哪个盘就行
打开文件,将以下4行注释掉



保存并退出
随后重启appium就可以啦
阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_30353203/article/details/79980814
个人分类: appium移动端自动化
上一篇android压力测试命令monkey详解
下一篇WEB请求处理二:Nginx请求反向代理
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭