1114. Family Property

This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 … Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID’s of this person’s parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi’s are the ID’s of his/her children; M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<math.h>
#include<vector> 
#include<cmath>
using namespace std;
struct node{
    int father;
    int M_estate;
    int Area;
    int key;
}arr[10000];
struct su{
    int father;
    int min;
    int num;
    double ar,estate;
    friend bool operator < (su a1,su a2)
    {
        if(fabs(a1.ar/a1.num-a2.ar/a2.num)>1e-6)
        {
            return a1.ar/a1.num<a2.ar/a2.num;
        }
        else
        return a1.min>a2.min;
    }
}arr2[1000];
int find(int num)
{
    if(arr[num].father==num)
    return num;
    else
    {
        arr[num].father=find(arr[num].father);
        return arr[num].father;
    }

}
int main()
{
    int N;
    for(int i=0;i<10000;i++)
    {
        arr[i].father=i;
        arr[i].key=0;
    }
    scanf("%d",&N);
    for(int i=0;i<N;i++)
    {
        int ID,Father,Mother,k,M_estate,Area;
        scanf("%d%d%d%d",&ID,&Father,&Mother,&k);
        arr[ID].key=1;
        if(Father!=-1)
        {
            arr[find(ID)].father=find(Father);
            arr[Father].key=1;
            if(Mother!=-1)
            {
                arr[find(Mother)].father=find(Father);
                arr[Mother].key=1;
            }

        }
        else
        {
            if(Mother!=-1)
            {
                arr[find(ID)].father=find(Mother);
                arr[Mother].key=1;
            }

        }
        for(int z=0;z<k;z++)
        {
            int child;
            scanf("%d",&child);
            arr[find(child)].father=find(ID);
            arr[child].key=1;

        }
        scanf("%d%d",&arr[ID].M_estate,&arr[ID].Area);

    }
    int count=0;
    for(int i=0;i<10000;i++)
    if(arr[i].father==i&&arr[i].key==1)
    {
        arr2[count].father=i;
        arr2[count].min=10000;
        arr2[count].num=0;
        arr2[count].ar=0;
        arr2[count].estate=0;
        count++;

    }

    for(int i=0;i<10000;i++)
    if(arr[i].key==1)
    {
        for(int k=0;k<count;k++)
        {
            if(arr2[k].father==find(i))
            {
                arr2[k].min=min(i,arr2[k].min);
                arr2[k].num++;
                arr2[k].ar+=arr[i].Area;
                arr2[k].estate+=arr[i].M_estate;
            }
        }
    }
    cout<<count<<endl;
    sort(arr2,arr2+count);
    for(int k=count-1;k>=0;k--)
    printf("%04d %d %.3lf %.3lf\n",arr2[k].min,arr2[k].num,arr2[k].estate/arr2[k].num,arr2[k].ar/arr2[k].num);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值