This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:
ID
Father
Mother
k Child1⋯Childk Mestate Area
where ID
is a unique 4-digit identification number for each person; Father
and Mother
are the ID
's of this person's parents (if a parent has passed away, -1
will be given instead); k (0≤k≤5) is the number of children of this person; Childi's are the ID
's of his/her children; Mestate is the total number of sets of the real estate under his/her name; and Area
is the total area of his/her estate.
Output Specification:
For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:
ID
M
AVGsets AVGarea
where ID
is the smallest ID in the family; M
is the total number of family members; AVGsets is the average number of sets of their real estate; and AVGarea is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.
Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000
思路:并查集!!!
程序:
#include <cstdio>
#include <algorithm>
using namespace std;
struct Data
{
int id,fid,mid,num,area;
int cid[10];
}data[1005];
struct node
{
int id,people;
double num,area;
bool flag = false;
}ans[10000];
int father[10000];
int visit[10000];
int find(int x)
{
while(x != father[x])
x = father[x];
return x;
}
void Union(int a,int b)
{
int faA = find(a);
int faB = find(b);
if(faA > faB)
father[faA] = faB;
else if(faA < faB)
father[faB] = faA;
}
int cmp1(node a,node b)
{
if(a.area != b.area)
return a.area > b.area;
else
return a.id < b.id;
}
int main()
{
int n,k,cnt = 0;
scanf("%d",&n);
for(int i = 0; i < 10000; i++)
{
father[i] = i;
}
for(int i = 0; i < n; i++)
{
scanf("%d %d %d %d",&data[i].id,&data[i].fid,&data[i].mid,&k);
visit[data[i].id] = true;
if(data[i].fid != -1)
{
visit[data[i].fid] = true;
Union(data[i].fid,data[i].id);
}
if(data[i].mid != -1)
{
visit[data[i].mid] = true;
Union(data[i].mid,data[i].id);
}
for(int j = 0; j < k; j++)
{
scanf("%d",&data[i].cid[j]);
visit[data[i].cid[j]] = true;
Union(data[i].cid[j],data[i].id);
}
scanf("%d %d",&data[i].num,&data[i].area);
}
for(int i = 0; i < n; i++)
{
int id = find(data[i].id);
ans[id].id = id;
ans[id].num += data[i].num;
ans[id].area += data[i].area;
ans[id].flag = true;
}
for(int i = 0; i < 10000; i++)
{
if(visit[i])
ans[find(i)].people++;
if(ans[i].flag)
cnt++;
}
for(int i = 0; i < 10000; i++)
{
if(ans[i].flag)
{
ans[i].num = (double)(ans[i].num * 1.0 / ans[i].people);
ans[i].area = (double)(ans[i].area * 1.0 / ans[i].people);
}
}
sort(ans,ans + 10000,cmp1);
printf("%d\n",cnt);
for(int i = 0; i < cnt; i++)
printf("%04d %d %.3lf %.3lf\n",ans[i].id,ans[i].people,ans[i].num,ans[i].area);
return 0;
}