UVALive - 7077 Assignments

Zu Chongzhi (429–500) was a prominent Chinese mathematician and astronomer during the Liu Song
and Southern Qi Dynasties. Zu calculated the value of| to the precision of six decimal places and for a
thousand years thereafter no subsequent mathematician computed a value this precise. Zu calculated
one year as 365.24281481 days, which is very close to 365.24219878 days as we know today. He also
worked on deducing the formula for the volume of a sphere.
It is said in some legend story books that when Zu was a little boy, he liked mathematical games.
One day, his father gave him some wood sticks as toys. Zu Chongzhi found a interesting problem using
them. He wanted to make some triangles by those sticks, and he wanted the total area of all triangles
he made to be as large as possible. The rules were :
1) A triangle could only consist of 3 sticks.
2) A triangle’s vertexes must be end points of sticks. A triangle’s vertex couldn’t be in the middle
of a stick.
3) Zu didn’t have to use all sticks.
Unfortunately, Zu didn’t solve that problem because it was an algorithm problem rather than a mathematical
problem. You can’t solve that problem without a computer if there are too many sticks. So
please bring your computer and go back to Zu’s time to help him so that maybe you can change the
history.
Input
There are no more than 10 test cases. For each case:
The first line is an integer N (3 ≤ N ≤ 12), indicating the number of sticks Zu Chongzhi had got.
The second line contains N integers, meaning the length of N sticks. The length of a stick is no more
than 100. The input ends with N = 0.
Output
For each test case, output the maximum total area of triangles Zu could make. Round the result to 2
digits after decimal point. If Zu couldn’t make any triangle, print ‘0.00’.
Sample Input
3
1 1 20
7
3 4 5 3 4 5 90
0
Sample Output
0.00
13.64
给出n个火车棒让你求出构成三角形的面积
三个一组用过了就不能再用了

#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
int judge(double a,double b,double c)
{
 if(a+b>c&&a+c>b&&b+c>a)
        return 1;
 return 0;
}
double zzzz(double a,double b,double c)
{
    double q=(a+b+c)/2;
    return sqrt(q*(q-a)*(q-b)*(q-c));
}

int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        double a[1003];
        for(int i=0;i<n;i++)
        {
            scanf("%lf",&a[i]);
        }
        sort(a,a+n);
        double ans=0.0;
        for(int i=n-1;i>=2;)
        {
            if(judge(a[i],a[i-1],a[i-2]))
            {
                ans+=zzzz(a[i],a[i-1],a[i-2]);
                i-=3;
            }
            else i--;
        }
        printf("%.2f\n",ans);

    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值