uvalive 5092 - Permutation Counting

Given a permutation a1, a2, … aN of {1, 2, … , N}, we define its E-value as the amount of elements
where ai > i. For example, the E-value of permutation {1, 3, 2, 4} is 1, while the E-value of {4, 3, 2, 1}
is 2. You are requested to find how many permutations of {1, 2, … , N} whose E-value is exactly k.
Input
There are several test cases, and one line for each case, which contains two integers, N and k. (1 ≤
N ≤ 1000, 0 ≤ k ≤ N).
Output
Output one line for each case. For the answer may be quite huge, you need to output the answer module
1,000,000,007.
Explanation for the sample:
There is only one permutation with E-value 0: {1, 2, 3}, and there are four permutations with
E-value 1: {1, 3, 2}, {2, 1, 3}, {3, 1, 2}, {3, 2, 1}
Sample Input
3 0
3 1
Sample Output
1
4
规律 递推出答案

#include<stdio.h>
#include<algorithm>
#include<math.h>
#define mod 1000000007
using namespace std;
//ditui
long long  a[1003][1003];
int main()
{

    for(int i=1; i<1002; i++)
    {
        a[i][0]=1;
        for(int j=1; j<=i; j++)
        {
            a[i][j]=((1+j)*a[i-1][j]+(i-j)*a[i-1][j-1])%mod;
        }
    }
    int n,k;
    while(~scanf("%d%d",&n,&k))
        printf("%lld\n",a[n][k]);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值