Tiles of Tetris, NOT!

看着题挺长的其实就是给你一个长方形

让你找出最小块数能够拼成正方形

数学题不做太多解释

B - Tiles of Tetris, NOT!

Time Limit: 1000 MS Memory Limit: 65536 KB

64-bit integer IO format: %lld , %llu Java class name: Main

[Submit] [Status]

Description

You’ve really messed up this time. “Go buy some square tiles” your supervisor told you. But as usual, you were either busy reading that message, answering that e-email, or updating your wall status on facebook. “Go buy some tiles” was all that you could remember. Your supervisor is now complaining that the tiles you bought were not squares and you’ll be fired if you don’t fix it!
“Fix it? How am I supposed to fix it?” you say to yourself. “I’m a programmer, The only tiles I know are those of the game Tetris!” There is no way you can afford to be fired either. This is your third job in less than a month. “I have to fix it!” you keep repeating.
You call the store you bought the tiles from, but they won’t take them back or even exchange. “We cannot cancel orders once the merchandise has left the store”, they tell you. You take a look at the tiles, they’re all rectangleshaped and all of the same size. You’d be losing a lot if you cut them, not that you’d be able to cut them into perfect squares in the first place. “Wait a minute!” you say to yourself. You grab a bunch of tiles, put them in some arrangement and Voila, that’s a square. But that won’t convince your boss.
Tiles are supposed to be small, and what you came-up with is rather big. You take another look at your arrangement, and it hits you again. “I’m on a roll today!” you say proudly to yourself.You just figured out how to find the smallest number of tiles needed to form the smallest possible square.

You rush and bring your supervisor to show him your discovery. He’s not that much impressed. You’re not making sense anyway (given all the blood rushing in your head trying to explain your algorithm.) You know that the calculation is definitely much simpler than what you’re saying, but you just can’t seem to think clearly.
Finally, your supervisor shouts: “First of all, the tiles have to be laid-down in the same orientation. Second, I’m running a construction site here, not a software shop! How do you expect the workers to figure out that number! You either write me a program to do the calculation you’re describing, or you go collect your netbook, your cell, your ipod, and your blackberry, and you get out of here this minute!”

Input

Your program will be tested on one or more data sets. Each test set is described on a single line made of two positive numbers: (0 < W,H < 1, 000, 000) which are the width and height of each tile. The last line is made of two zeros.
 

Output

For each test case, write the answer on a separate line.

Sample Input

2 3
1 2
0 0

Sample Output

6
2

Hint

Big result, __int64 / long long is recommended.


#include<stdio.h>
//已知一个长方形求最少的块数拼成正方形
#define ll long long

int main()
{
    ll n,m;
    while(~scanf("%lld%lld",&n,&m))
    {
        if(n==0||m==0)
            break;

        if(n>=m)
        {
            if(n%m)
                printf("%lld\n",n*m);
            else printf("%lld\n",n/m);
        }
        else
        {
            if(m%n)
                printf("%lld\n",n*m);
            else printf("%lld\n",m/n);
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值