hrbust Function Run Fun

这题就怕te

递归可以

也可以直接迭代出所有情况

关系式别看错了就好

Function Run Fun
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 380(184 users)Total Accepted: 198(170 users)Rating: Special Judge: No
Description

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 


if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output

Print the value for w(a,b,c) for each triple.

Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1
Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

解法一(递归并记录路径)

#include<stdio.h>
#include<string.h>
int re[25][25][25];
int w(int a,int b,int c)
{
   if (a <= 0 || b <= 0 || c <= 0)
    return 1;
    if(re[a][b][c])
        return re[a][b][c];
    if(a > 20 | b > 20 | c > 20)
    return w(20,20,20);
   if(a < b && b < c)
    return re[a][b][c]=w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) ;
    return re[a][b][c]=w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) ;


}
int main()
{
    int n,m,z;
    memset(re,0,sizeof(re));
    while(~scanf("%d%d%d",&n,&m,&z))
    {
        if(n==-1&&m==-1&&z==-1)break;
        if(n<=0||m<=0||z<=0)
            printf("w(%d, %d, %d) = 1\n",n,m,z);
        else if(n>20||m>20||z>20)
            printf("w(%d, %d, %d) = %d\n",n,m,z,w(20,20,20));
        else printf("w(%d, %d, %d) = %d\n",n,m,z,w(n,m,z));
    }
}

解法二 迭代

#include<stdio.h>
int a[25][25][25];
int main()
{
    for(int i=0; i<=20; i++)
    {
        for(int j=0; j<=20; j++)
        {
            for(int k=0; k<=20; k++)
            {
                if(i==0||j==0||k==0)
                {
                    a[i][j][k]=1;
                    continue;
                }
                if(i<j&&j<k)
                    a[i][j][k]=a[i][j][k-1]+a[i][j-1][k-1]-a[i][j-1][k];
                else a[i][j][k]= a[i-1][j][k]+a[i-1][j-1][k]+a[i-1][j][k-1]-a[i-1][j-1][k-1];
                // printf("%d ",a[i][j][k]);
            }
          //  printf("\n");
        }
        //printf("\n");
    }
    int n,m,z;
    while(~scanf("%d%d%d",&n,&m,&z))
    {
        if(n==-1&&m==-1&&z==-1)break;
        if(n<=0||m<=0||z<=0)
            printf("w(%d, %d, %d) = 1\n",n,m,z);
        else if(n>20||m>20||z>20)
            printf("w(%d, %d, %d) = %d\n",n,m,z,a[20][20][20]);
        else printf("w(%d, %d, %d) = %d\n",n,m,z,a[n][m][z]);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值