hdu 4282

不说了数据太小水一发就好了。

1031: A very hard mathematic problem(less data)

Time Limit: 1 Sec   Memory Limit: 32 MB
Submit: 63   Solved: 10
[ Submit][ Status][ Web Board]

Description

Hill is very good at solving mathematic problems. Today he is working a problem like this: 
Find three positive integers X, Y and Z (X < Y, Z > 1) that holds
X^Z + Y^Z + XYZ = K
where K is another given integer.
Here the operator “^” means power, e.g., 2^3 = 2 * 2 * 2.
Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions?
Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem.
Now, it’s your turn.

Input

There are multiple test cases. 
For each case, there is only one integer K (0 < K < 2^31) in a line.
K = 0 implies the end of input.


Output

Output the total number of solutions in a line for each test case.

Sample Input

9
53
6
0

Sample Output

1
1
0

HINT

 9 = 1^2 + 2^2 + 1 * 2 * 2

53 = 2^3 + 3^3 + 2 * 3 * 3

Source

暴力枚举z就可以了。z肯定比较小的。
当z等于2时就是平方和公式。

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;

long long pow(long long a,int n)
{
    long long ret=1;
    long long temp=a;
    while(n)
    {
        if(n&1)ret*=temp;
        temp*=temp;
        n>>=1;
    }
    return ret;
}
int main()
{
    long long K;
    long long ans;
    while(scanf("%I64d",&K),K)
    {
        ans=0;
        long long temp=(long long)sqrt(K);
        if(temp*temp==K)ans+=(temp-1)/2;
        for(int z=3;z<31;z++)
        {
            for(long long x=1;;x++)
            {
                long long u=pow(x,z);
                if(u*2>=K)break;
                for(long long y=x+1;;y++)
                {
                    long long v=pow(y,z);
                    if(u+v+x*y*z>K)break;
                    if(u+v+x*y*z==K)ans++;
                }
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值