FZU - 2213 Common Tangents(几何)

Two different circles can have at most four common tangents.

The picture below is an illustration of two circles with four common tangents.

Now given the center and radius of two circles, your job is to find how many common tangents between them.

Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, there is one line contains six integers x1 (−100 ≤ x1 ≤ 100), y1 (−100 ≤ y1 ≤ 100), r1 (0 < r1 ≤ 200), x2 (−100 ≤ x2 ≤ 100), y2 (−100 ≤ y2 ≤ 100), r2 (0 < r2 ≤ 200). Here (x1, y1) and (x2, y2) are the coordinates of the center of the first circle and second circle respectively, r1 is the radius of the first circle and r2 is the radius of the second circle.

Output

For each test case, output the corresponding answer in one line.

If there is infinite number of tangents between the two circles then output -1.

Sample Input
3
10 10 5 20 20 5
10 10 10 20 20 10
10 10 5 20 10 5
Sample Output
4
2
3
Hint




若两圆半径不等,则:
当两圆外离时,有4条公切线; 
当两圆内含时,没有公切线; 
当两圆外切时,有3条公切线; 
当两圆内切时,有1条公切线; 
当两圆相交时,有2条公切线.
若两圆半径相等,则:
当两圆外离时,有4条公切线;
当两圆外切时,有3条公切线;
当两圆相交时,有2条公切线;
当两圆重合时,有无数条公切线.

#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int distance(int x1,int y1,int x2,int y2)
{
    return (x1-x2)*(x1-x2)+(y1-y2)*(y1-y2) ;
}
int main()
{
    int x1,x2,y1,y2,r1,r2;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d%d%d%d",&x1,&y1,&r1,&x2,&y2,&r2);
        if(r1==r2)
        {
            int  dis=distance(x1,y1,x2,y2);
            if(dis==0)
            {
                printf("-1\n");
            }
            else if(dis>(r1+r2)*(r1+r2))
            {
                printf("4\n");
            }
            else if(dis==(r1+r2)*(r1+r2))
            {
                printf("3\n");
            }
            else
            {
                printf("2\n");
            }
        }
        else
        {
            double dis=distance(x1,y1,x2,y2);
            dis=sqrt(dis);
            if(dis>(r1+r2))
            {
                printf("4\n");
            }
            if(dis==(r1+r2))
            {
                printf("3\n");
            }
            else if(dis==fabs(r1-r2))
            {
                printf("1\n");
            }
            else if(dis<(r1+r2)&&dis>fabs(r1-r2))
                printf("2\n");
            else printf("0\n");
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值