Common Tangents

Two different circles can have at most four common tangents.

The picture below is an illustration of two circles with four common tangents.


Now given the center and radius of two circles, your job is to find how many common tangents between them.

Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, there is one line contains six integers x1 (−100 ≤ x1 ≤ 100), y1 (−100 ≤ y1 ≤ 100), r1 (0 < r1 ≤ 200), x2 (−100 ≤ x2 ≤ 100), y2 (−100 ≤ y2 ≤ 100), r2 (0 < r2 ≤ 200). Here (x1, y1) and (x2, y2) are the coordinates of the center of the first circle and second circle respectively, r1 is the radius of the first circle and r2 is the radius of the second circle.

Output

For each test case, output the corresponding answer in one line.

If there is infinite number of tangents between the two circles then output -1.

Sample Input
3
10 10 5 20 20 5
10 10 10 20 20 10
10 10 5 20 10 5
Sample Output
4
2
3
题意:给两个圆的圆心坐标和半径,求两个圆的公切线有几条,如果有无数条,则输出-1.
思路:1)当两个圆完全重合时有无数条公切线;
2)当两个圆的圆心距大于两个圆半径和的时候(两个圆外离),此时有4条公切线;
3)当两个圆的圆心距等于两个圆的半径和的时候(两圆外切),此时有3条公切线;
4)当两个圆的圆心距小于两个圆的半径和的时候
<1>两个圆的圆心距等于两个圆的半径之差(两圆内切),此时有1条公切线;
<2>当圆心距大于两个圆的半径时(两圆相交),此时有2条公切线;
<3>剩余情况,两圆内含时,有0条公切线。
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
double Delc(double x1,double y1,double x2,double y2)
{
    double num=0;
    num=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
    return num;
}
int main()
{
    int t;
    double x1,y1,r1,x2,y2,r2;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf %lf %lf %lf %lf %lf",&x1,&y1,&r1,&x2,&y2,&r2);
        int dis=Delc(x1,y1,x2,y2);
        if (x1==x2&&y1==y2&&r1==r2)
            printf("-1\n");
        else
        {
            if(dis>r1+r2)
                printf("4\n");
            else if(dis==r1+r2)
                printf("3\n");
            else if(dis<r1+r2)
            {
                if(dis==fabs(r1-r2))
                    printf("1\n");
                else if(dis>r1&&dis>r2)
                    printf("2\n");
                else
                    printf("0\n");
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值