杭电1398

        Square Coins

Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, …, and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input
2
10
30
0

Sample Output
1
4
27


题意:火星上的货币有1,4,9,16,25…..2^17这17中面值的硬币,问任意给定一个不大于300的正整数面额,用这些硬币来组成此面额总共有多少种组合种数。
一看题目就确定是母函数问题


对应的母函数:
(1+x+x^2+x^3+…)(1+x^4+x^8+…..)(1+x^9+x^18)……………………….

代码1:

# include <iostream>

using namespace std;

int main(){

    int n,i,j,k;
    int c1[301],c2[301];

    while(cin>>n,n!=0){

        for(i=0;i<=n;i++){
            c1[i] = 1;
            c2[i] = 0;
        }

        for(i=2;i<=n;i++){//第i项 
            for(j=0;j<=n;j++){//i-1项符合条件的 
                //x^(k+j)<=x^n
                for(k=0;k+j<=n;k+=i*i){//第i项的每一个数 
                    c2[j+k] += c1[j];   
                }
            }

            for(k=0;k<=n;k++){
                c1[k] = c2[k];
                c2[k] = 0;
            } 
        }

        cout<<c1[n]<<endl;

    }


    return 0;
}

代码2:
# include <iostream>

using namespace std;

# define max 306

int c1[max],c2[max];
int main(){

    int n,i,j,k;

    for(i=0;i<=303;i++){
        c1[i] = 1;
        c2[i] = 0;
    }

    for(i=2;i<303;i++){
        for(j=0;j<303;j++){
            for(k=0;k+j<303;k+=i*i){
                c2[j+k] += c1[j];
            }
        }

        for(k=0;k<303;k++){
            c1[k] = c2[k];
            c2[k] = 0;
        }
    }

    while(cin>>n,n!=0){
        cout<<c1[n]<<endl;
    }




    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值