回文词

Sample Input
NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA
Sample Output
NOTAPALINDROME -- is not a palindrome.
ISAPALINILAPASI -- is a regular palindrome.
2A3MEAS -- is a mirrored string.
ATOYOTA -- is a mirrored palindrome.

#include<stdio.h>
#include<string.h>
#include<ctype.h>


char r(char ch)
{
    char jingxiang[]="A   3  HIL JM O   2TUVWXY51SE Z  8 ";
    if(isalpha(ch))
        return jingxiang[ch-'A'];
    return jingxiang[ch-'0'+25];
}

int main ()
{
    char c[30];
    int len, p, m, i;
    while (scanf("%s",c)!=EOF)
    {
        char d[30];
        len=strlen(c);
        p=m=1;
        for(i=0;i<len;i++)
        {
            if(c[i]!=c[len-1-i]) p=0;
            if(r(c[i])!=c[len-1-i]) m=0;
        }
        if(m==0&&p==0) strcpy(d, "not a palindrome");
        else if(m==0&&p==1) strcpy(d, "a regular palindrome");
        else if(m==1&&p==0) strcpy(d, "a mirrored string");
        else strcpy(d, "a mirrored palindrome");
        printf("%s -- is %s.\n\n", c, d);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

hhjian6666

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值