5714:Chtholly's request(N个偶数位回文串和,小技巧)

5714: Chtholly's request

时间限制: 2 Sec   内存限制: 256 MB
提交: 136   解决: 55
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

— Thanks a lot for today.
— I experienced so many great things.

— You gave me memories like dreams... But I have to leave now...

— One last request, can you...

— Help me solve a Codeforces problem?

— ......

— What?

Chtholly has been thinking about a problem for days:

If a number is palindrome and length of its decimal representation without leading zeros is even, we call it a zcy number. A number is palindrome means when written in decimal representation, it contains no leading zeros and reads the same forwards and backwards. For example 12321 and 1221 are palindromes and 123 and 12451 are not. Moreover, 1221 is zcy number and 12321 is not.

Given integers k and p, calculate the sum of the k smallest zcy numbers and output this sum modulo p.

Unfortunately, Willem isn't good at solving this kind of problems, so he asks you for help!

输入

The first line contains two integers k and p (1≤k≤105,1≤p≤109).

输出

Output single integer — answer to the problem.

样例输入

2 100

样例输出

33

提示

In the first example, the smallest zcy number is 11, and the second smallest zcy number is 22.

#include<stdio.h>
int main()
{
    long long x, y, k, p, sum;
    scanf("%lld%lld", &k, &p);
    for(long long i=1; i<=k; i++)
    {    
            x=i;  
            y=i;  
            while(y)
            {  
                x=x*10+y%10;  
                y/=10;  
            }  
            sum=(sum+x)%p;  
    }  
    printf("%lld\n", sum);
    return 0;
}
/**************************************************************
    Problem: 5714
    User: ldu_reserver201701
    Language: C++
    Result: 正确
    Time:8 ms
    Memory:1092 kb
****************************************************************/

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

hhjian6666

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值